Power outage during update to MS7 - YaST not working

My power went out while I was updating to milestone 7 (or at least I assume it was still updating. Perhaps it was done by the time the fuse blew, don’t know.)

Anyhow, some parts of YaST no longer work, most importantly… YaST software management isn’t working from the shell nor the GUI.
Getting the error:

Error while creating client_module sw_single

So I tried to fix it…

zypper up -t yast2*
zypper: error while loading shared libraries: librpm-4.4.so: cannot open shared object file: No such file or directory
smart upgrade yast2*
If 'smart' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf smart

How do I proceed

This may help?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 4 days 18:25, 2 users, load average: 0.45, 0.46, 0.45
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Not very likely:

zypper: error while loading shared libraries: **librpm-4.4.so**: cannot
open shared object file: No such file or directory 

With some luck plain RPM will still work, but zypper/YaST won’t as they seem to be linked against RPM 4.4 while (just a guess) RPM itself has already been updated to 4.7.

(This is one of the real disadvantages of zypper compared to smart/apt, they won’t start updating any packages before all of them are actually downloaded, which of course then has other disadvantages.)

Do you have the Milestone7 CD? Boot from it, enter installer and choose ‘Upgrade installed system’. This should fix what went wrong. At least it should finish the interrupted upgrade.

This thread is about why zypper should do as default:

zypper dup -d && zypper dup

Default zypper does these different tasks in parallel. But this is totally broken. Please vote against this “feature” on fate!
(No good distribution offers such a going to brake upgrade procedure.)

You cannot change the subject of a thread through content of a post. Axeia got stuck in the middle of updating due to the power outage in Neurenberg. The power outage is over, haven’t seen Axeia back, so I guess that’s solved.
About your call for votes: please start a new thread in Prerelease/Betas.