power management settings

I turned off all power management settings yet, after some time my notebook continues to go to a screen requiring password.
How do I not go to this screen?

Notebook itself perhaps… any setting in the BIOS? I once had an old Hewlett Packard, albeit a desktop, that did that.

If not… What desktop environment are you using?

I am using the KDE
My noteBook is an Asus 2 years old and the BIOS don’t shows that issue

Hmm… strange. Seems to work for me OK, although this a desktop, I don’t know how, or if, power management may be different on a laptop/notebook.

Just checked on a system running 42.3

System Settings -> Power Management -> Energy Saving

I’ve set “Suspend Session” “After” to 1min for the purposes of testing, with the action performed as “Lock Screen”

If “Suspend Session” is ticked then the screen locks as expected.

After un-ticking “Suspend Session” and “Apply” the screen remains unlocked as expected.

Does the same thing happen if you create a new test user?

With a new test user it not happen.

Try renaming “~/.config/powermanagementprofilesrc” of the non-working user to, for example, “~/.config/powermanagementprofilesrc.old”

Then log in as the non-working user and set the Power Management options as you require, a new “powermanagementprofilesrc” will be created.

I tried the above and many others to try to solve the problem with power management. Nothing solved.

I also noticed that there are other problems that can not find solution, for example the double-click on the desktop does not work

I have 4 other machines in my job, all with Leap and different from when I operated with OpenSuse 13.2 or older, now with Leap all machines have some kind of insoluble problem

So I decided to try with other Linux distributions with this noteBook
If the problems continue, I will re-use Leap

But, thank you so much for the effort.

I think this is an issue with sddm
I know it sounds silly but I’m pretty sure it’s sddm asking for a user password (it’s the same login screen as sddm uses after boot)
this has been bugging me for some time now (especially sddm having Num Lock set to off by default) but I’ve been too lazy to investigate (the Num Lock is solvable by editing /etc/sddm.conf but updates undo changes)

It’s not a power management configuration issue. Check the screen-locking settings…

System Settings > Desktop Behaviour > Screen Locking

The pertinent Plasma 5 config file is ~/.config/kscreenlockerrc

As I said before, there were other problems (double click on the desktop) and also the screen-locking settings never made the changes

I saw no explicit reference made to the screen locking settings, (and I’m not experiencing any such issue with my openSUSE Leap 42.3, Plasma 5 desktop). I prefer commands and output to vague descriptions. Show us the config in ~/.config/kscreenlockerrc

Sorry, I’ve already removed Leap from NoteBook with this problem.
If I make a new installation I will put here the result that you requested