Postfix startup on boot (OpenSUSE 12.2)

I have just installed OpenSUSE 12.2 and have tried to configure Postfix on it. While the server runs fine, systemd is not starting it as a part of the boot process - I have to manually start it up. As far as I can tell systemd is not even attempting to start it - there are certainly no error in the log files.

I’ve been using OpenSUSE for a long time now (ever since 10.0) so I am no novice. However systemd is completely new to me and I cannot think for the life of me what the problem could be. Any suggestions would be must appreciated.

Thanks

Alan

And if you open up terminal after a reboot but before you “restart postfix”, what do you get?

/sbin/service postfix status

I see this and I do not restart postfix myself on restart:

postfix.service - Postfix Mail Transport Agent
          Loaded: loaded (/lib/systemd/system/postfix.service; enabled)
          Active:** active (running) **since Tue, 25 Dec 2012 05:47:07 -0600; 2 days ago
        Main PID: 1759 (master)
          CGroup: name=systemd:/system/postfix.service
                  ├ 1759 /usr/lib/postfix/master
                  ├ 1762 qmgr -l -t fifo -u
                  ├ 2722 pickup -l -t fifo -u
                  └ control

So I had a problem with dkms not working under systemd and this is what I did.

https://forums.opensuse.org/blogs/jdmcdaniel3/dkms-systemd-how-get-dynamic-kernel-module-support-work-opensuse-12-1-100/

And when I found the after.local file did not work under systemd, this is what I did:

https://forums.opensuse.org/blogs/jdmcdaniel3/systemd-using-after-local-script-opensuse-12-1-71/

But I am not sure this is the issue you have.

Thank You,

On 2012-12-27 22:06, alanhants wrote:
>
> I have just installed OpenSUSE 12.2 and have tried to configure Postfix
> on it. While the server runs fine, systemd is not starting it as a part
> of the boot process - I have to manually start it up. As far as I can
> tell systemd is not even attempting to start it - there are certainly no
> error in the log files.
>
> I’ve been using OpenSUSE for a long time now (ever since 10.0) so I am
> no novice. However systemd is completely new to me and I cannot think
> for the life of me what the problem could be. Any suggestions would be
> must appreciated.

Someone explained recently how systemd works, and now I can not find the
post. It seems that systemd doesn’t really start some services, but
instead opens the socket and waits till someone tries to use it to
really start the associated service.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

systemd can do it, but it does not mean it does it for all services (or that it is even possible to do for all services). postfix is not socket activated, it is started normally:

ExecStart=/usr/sbin/postfix start

Response from the service postfix status command:

postfix.service - Postfix Mail Transport Agent
          Loaded: loaded (/lib/systemd/system/postfix.service; enabled)
          Active: inactive (dead)
          CGroup: name=systemd:/system/postfix.service

I really hope someone has some ideas on this because I am completely stuck with this.

Alan

bor@opensuse:~> systemctl status postfix.service
postfix.service - Postfix Mail Transport Agent
      Loaded: loaded (/lib/systemd/system/postfix.service; disabled)
      Active: inactive (dead)
      CGroup: name=systemd:/system/postfix.service

bor@opensuse:~> systemctl is-enabled postfix.service
disabled
bor@opensuse:~> sudo systemctl start postfix.service
root's password:
bor@opensuse:~> systemctl status postfix.service
postfix.service - Postfix Mail Transport Agent
      Loaded: loaded (/lib/systemd/system/postfix.service; disabled)
      Active: active (running) since Fri, 28 Dec 2012 22:19:12 +0400; 2s ago
     Process: 6177 ExecStartPost=/etc/postfix/system/cond_slp register (code=exited, status=0/SUCCESS)
     Process: 6171 ExecStartPost=/etc/postfix/system/wait_qmgr 60 (code=exited, status=0/SUCCESS)
     Process: 6100 ExecStart=/usr/sbin/postfix start (code=exited, status=0/SUCCESS)
     Process: 6081 ExecStartPre=/etc/postfix/system/update_postmaps (code=exited, status=0/SUCCESS)
     Process: 6078 ExecStartPre=/etc/postfix/system/update_chroot (code=exited, status=0/SUCCESS)
     Process: 6074 ExecStartPre=/bin/echo Starting mail service (Postfix) (code=exited, status=0/SUCCESS)
    Main PID: 6170 (master)
      CGroup: name=systemd:/system/postfix.service
          ├ 6170 /usr/lib/postfix/master
          ├ 6172 pickup -l -t fifo -u
          ├ 6173 qmgr -l -t fifo -u
          └ control

bor@opensuse:~> 

and the last one, which I personally do not need so I skipped it

bor@opensuse:~> sudo systemctl enable postfix.service
ln -s '/lib/systemd/system/postfix.service' '/etc/systemd/system/multi-user.target.wants/postfix.service'
bor@opensuse:~> 

I’ve been through all of these steps (in fact they were the first things I did) with no joy.

I’m going to try to reinstall 12.2 and see if it makes a difference. I’ve had some problems with SLES recently in the YaST system backup works on one installation, but refuses to work on another one.

Alan