Post-install Sony Vaio VGC-JS1E Screen Problems


I am a complete newbie to Linux. I have installed OpenSuse 12.1 on an empty 500Gb disk on a Sony Vaio VGC-JS1E machine. I have two problems that are driving me crazy right now.

  1. I previously ran Windows 7 successfully on the machine. After completing the automatic install, the screen contains a small view of the KDE desktop (I have also tried Gnome with the same effect) surrounded by on the right of the screen a multi-coloured two-inch border and on the bottom of the screen a four inch area that is blank. The two border are not accessible and the window is confined to a small area oriniating in the left top corner. I ahve tried using the built-in tools to change the screen resolution with no success. I have also tried reinstalling the software three times with no luck.

  2. The wireless network is not enabled post install. I have gone through network manager checking that it is running and that the network services are turned on - they are. I have configured the network and started it successfully. However, on reboot, the network is not available and, the settings I have entered are turned off once again.

I suspect I may not be doing something correctly. I would really appreciate any help that you can offer this poor soul struggling away here trying to fix these two problems.

Many thanks for your time - and, thanks too for helping out in this way. This forum and the others are really useful.

  1. I do not know real answer, but I have had this trying various Linux distributions. It is i think graphics related, and needs a line in boot set up to set Video to say specific value and also to remove certain starts up. (e.g. noapic or similar)
  2. Can you post the graphics set up of the laptop: Intel or specific graphics card? Others may help.
    3 Cheat sheet parts for boot loading alteration include (with respect to Knoppix):
    noapic noagp noapm nodma nomce nofirewire nopcmcia noscsi noswap nousb nosmp noaudio OR vga=normal

Try nomodeset typed at the boot screen.

Google search shows this machine has a Graphics: Intel® Graphics Media Accelerator X4500HD is that right??

Thank you for your reply - I have an Intel accelerator card on the desktop machine.

Yes this is true :-(. It seems to cause a great deal of problems I understand from Googling it. Could you tell me please how I may type ‘nomodeset’ at the boot screen.

Thank you

“nomodeset” partly worked - now the screen image is centred but its set to 1024x768 and it’s the only resolution setting available. Also the screen is set to default not LDVI etc. Could you advise please how I may change the resolution to 1680x1050.

I’ve tried doing this through Yast/KDE with no luck.


Do you know what driver is being used? nomodeset forces a lower capable driver. Look in the my computer icon should tell you what is being used.

I suspect the Intel driver problem may be fixed in a newer kernel since the Intel driver is now part of the kernel .

Hi gogalthorp - the driver I am suing is an Intel Graphics Media Accelerator X4500HD and the standard resolution for the screen on the Sony Vaio VGC-JS1E desktop is 1680x1050.

Does your suspicion that the Intel driver problem may be fixed in a new kernel mean that I have to wait for the new kernel to be developed and released before I can use OpenSuse on this machine? I’m sorry to ask so many naive questions - I really am a newbie and not too sure what I am doing :).

‘using’ not ‘suing’

Sorry but I don’t use Intel graphics so I may not be the best to advise

After the install did you do a update?

Did you look at the screen setting in Personal Settings-Display and Monitor to see if you have other choices???