Post install fail - is it my computer?

I recently reinstalled openSUSE 13.2 with a dual boot - with success! Grub opened both Windosw and OS. Then got a wild hair and installed the newest Tumbleweed. While Grub2 opens Windows fine, it fails to start Tumbleweed. It tries and then the screen goes blank. Have to turn off the computer and restart.

Funny thing is that the same thing happens with all attempts to install newer distros (Mageia, MX, Debian, Manjaro). Is seems to mean there is something about my computer that is incompatible with newer linux distros. The BIOS is set to UEFI/Legacy. Tried UEFI only, but Grub2 wouldn’t load, so went back.

Would a new motherboard solve my problem?

Motherboard: MSI A78M-E35
BIOS: E7721AMS v30.6

Just in case it might be helpful:
Boot Override

  • SATA2: HL-DT-ST DVDRAM GH22N550
  • UEFI: Builtin EFI Shell
  • SATA1: ST1000DM003-ISB102

IMHO this should be fixable, by taking over the installed system from a live/install USB

  1. If you want to boot EFI you need to install booting the installer in EFI mode. It is unclear how you installed and how Windows is install. Note all OS must use the same boot method.

  2. You did not tell what Graphic card you have or what GPU.

It sounds like a graphics problem but there is not enough info to be certain

Using nomodeset may enable an otherwise normal installation of Leap or Tumbleweed.

It turned out to be nomodeset! Thanks to MRMAZDA.

I went to LinuxQuestions.org and asked about the problem. I was instructed to edit the bootloader and add “nomodeset” to the end of the linux line. It worked.

nomodeset

The newest kernels have moved the video mode setting into the kernel. So all the programming of the hardware specific clock rates and registers on the video card happen in the kernel rather than in the X driver when the X server starts… This makes it possible to have high resolution nice looking splash (boot) screens and flicker free transitions from boot splash to login screen. Unfortunately, on some cards this doesn’t work properly and you end up with a black screen. Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded. I have an older Radeon graphics on an AMD A8 processor.