Possible Solution To 11.3 Flash Sound Issue

I have noticed in the forums and experienced for myself that OpenSUSE 11.3 Flash player sound does not work while other applications do have sound. For example, Amarok runs just fine while youtube videos do not have any sound. I got mine to work and here is how.

The solution was to compare my old distro (11.1) to what I currently have (11.3). I went into Yast and found that all of my sound parameters were the same. I then went into Yast->Software Management and found that I had different pulse libraries installed. I changed my 11.3 to what was in 11.1 and it worked.

In particular, do not have pulse running on your system. Go into Yast->Software Management and do a search with the word pulse. Delete everything related to pulse except for the following:

Make sure that you kill any pulse audio processes that are running. Then try flash and Amarok. On my system both worked. I also had libpulse-browse0 in and flash worked. I have not yet tried to remove the three above to see if they all can be removed. I also confirmed that both Amarok and Flash could be simultaneously heard.

I hope this helps.