Possible new problem with mkinitrd or newest Tumbleweed kernel-default

I was unable to boot after an upgrade to kernel-default-3-5-* and have possibly traced the source to mkinitrd. I was able to boot into failsafe mode, although it seemed to be very buggy. The output of mkinitrd includes the following errors:

modprobe: Module kernel not found.
WARNING: no dependencies for kernel module ‘kernel’ found.

I have downgraded to kernel-default-3-1-* and am able to boot once again, but still get the mkinitrd error. Does a module named "kernel" exist? 

I am in the process of upgrading the kernel again and have removed the "quiet" switch from /boot/grub/menu.lst so that I may get a more verbose output. If I see anything useful, I'll try to post it. 

Hardware is an Acer Ferrari 4006WLMi, which is an early 64 bit laptop. Processor is a Turion ML40 running at 2.2GHz if I remember correctly. I have 2GB of DDR333 RAM installed. Windows XP still works correctly. This laptop has worked flawlessly from OpenSuSE 8.* until just now.

While I have no idea about Tumbleweed at all, just one thought:
What mkinitrd version do you have, kernel 3.5 needs mkinitrd-2.7.1,
2.7.0 leads to problems.

PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

I have this kernel/initrd combo:


No problems.
Are you running openSUSE 12.1 or Tumbleweed, or some hybrid?

Am 16.08.2012 07:16, schrieb swerdna:
> I have this kernel/initrd combo:
> Code:
> --------------------
> mkinitrd-2.7.1-4.1.x86_64
> kernel-desktop-3.5.1-38.1.x86_64
> --------------------
> No problems.

Dito, with openSUSE 12.1 64bit, no problems, mine are slightly different
versions from kernel:stable


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Gentleman, and specialy the OP, there is a Tumbleweed forum! That is where the Tumblefeed fans are.

I will move this there. Please refrain from posting until moved.

Moved and open again.

Thanks to hcvv for moving this to the correct forum. To answer the questions, I updated to kernel-default-3.5.2-38.1.x86_64 and am running mkinitrd 2.7.1-4.1.x86_64, both from Tumbleweed. I have two other 64 bit machines running the same configuration with no problems. Since the laptop will boot into failsafe mode correctly, it leads me to believe that the Radeon X700 may be the source of the problem with X, as support for this card is dwindling. It has worked well up until now, even with many desktop effects enabled. My desktops run much newer ATI / AMD cards.

My apologies. as I seem to have been reporting two separate problems in the same post. At first, I assumed that the failure of X under normal boot, and the mkinitrd errors were related. It may not be the case.

I posted about the mkinitrd error listed in my original post only because it seemed very odd. The mkinitrd error is 100% repeatable, regardless of kernel version, on my laptop. I do not get the error with my desktops. I am assuming that either hardware, or the kernel / initrd configuration files are responsible. I have re-installed OpenSuSE 12.1 and will upgrade again to the same packages to see if I get the same error. This may be some kind of a fluke and I think it would be prudent to see if it is repeatable. It may take a few days to get all of the upgrades done. I’ll post back regardless of the outcome so that everyone will be informed. Thanks for all responses.

While I can not yet comment about the problem with X as I am still downloading updates, I can confirm that the mkinitrd error is still there, even with the standard 12.1 Desktop kernel and mkinitrd. I have rebooted more than once and assume the error may be harmless. It is a curious message though. I do need to admit that the error may have been there for a long time. I may have only noticed it when the other problem occurred. I’ll post tomorrow concerning the results after upgrade.

I have finished the upgrades and this appears to be repeatable. My laptop will no longer boot without failsafe. It may be that the newer kernel does not like my Radeon X700. When bootiing normally and verbosely, the last error I get is concerning a framebuffer error between radeondrmfb and VESA fb. That may be the warning flag, but I do not know how to interpret it. I will try backing to kernel-desktop 3.5.0 and see if that works. When I originally upgraded, I am not sure what kernel I was upgrading from. Any suggestions would be greatly appreciated. If it is suggested as a bug, should I file against the kernel, or OpenSuSE?

Apparently kernel 3.5 is where this problem started. I ended up downgrading to 3.4.* to get a useable system. This problem seems to be unique to only my laptop, so I wouldn’t place any urgency on it.

I locked my kernel version until I have time to dig deeper concerning a root cause of this. Thanks for all responses.

I just installed a bunch of updates too on one of my systems. I can’t boot either. My Tumbleweed setup had been rather flawless until now. In failsafe, it gets stuck right at the firewal stage. Thankfully, if I press Enter it continues and gives me a login prompt. My guess is that the problem lies with the nvidia upgrade. The additional problem I am having is that that machine is connected to the Internet through wifi, and in failsafe I don’t know how to connect to the network.

I am sorry for hijacking this thread. It seemed to me that the issue I am having is related, but I think my issue is different. I thought that after the last zypper dup upgrade, the mentioned 3.5 kernel would have been installed. However, when I type uname -a, it says that I am using the 3.1.10-1-desktop kernel. So, my issue is probably not related. I am going to start a different thread.