Possible bugs

After recently upgrading to 13.1-Gnome, I’ve encountered 3 applications or functions that I don’t seem to be able to get to work properly, and may need some attention from the developers: First, Ekiga is no longer able to contact my SIP provider, Diamondcard, and always responds that the provider’s server is offline. I’ve worked around this by installing Twinkle, which seems to function well, though it comes with a great deal of KDE baggage. Second, the provided version of gnupg always stores one’s pgp password for as long as he remains logged in, even when the box asking whether you want to do so is explicitly un-checked. I consider this a security risk. Finally, while perhaps not a bug, and not exactly an application, either, I’d appreciate any advice regarding how to incorporate the “Euro” third-level key on “5” while still using the en_US keymap. This feature has worked fine in previous SuSE versions and with Gnome 3 as provided in other distros - some of which even explicitly offer a “US QWERTY with Euro on 5” keymap. I’ve tried enabling the “euro on 5” feature found in the Tweak tool, tried using Xmodmap, changing the RC_LANG variable in the environment, modifying etc/sysconfig/keyboard to include a small, custom “compose” file, and attempted to add the euro character to /usr/share/kbd/keymaps/i396/qwerty/us.map.gz. None of these efforts, or combinations thereof, seem to produce the desired (or any other) effect. And yes, I’m aware of the us-international or us.accentos map, which does include the euro, but the extensive “compose” features of this keymap makes typing the ordinary and often-used apostrophe difficult and counterintuitive. At any rate, the developers might want to consider following the example of other distros and providing a “US English with Euro on 5” keymap, since this perfectly describes many, if not most, Continental European QWERTY keyboards.

You need to (sorry, everything approximate back translation into English, I use different language)

  1. add keyboard layout “English with Euro on 5” via “Language and Region”. You will need to first display full list via ellipses and then go for Other (or may be More) to find it
  2. add modifier to switch to third level in Keyboard settings (in my case it was disabled by default)

Yes, this certainly should work…but even entering these settings and rebooting changes nothing. Thanks for reminding me about the user “settings” on the task bar. Until now, I had only been trying settings in YaST and the Gnome Tweak tool.

Finally! With a big thanks to the advice of arvidjaar, I have it working. The trick is to do exactly as he suggests using the settings menu on the taskbar, then using the Gnome Tweak tool to enable “Typing -> Adding currency signs to certain keys -> euro on 5”, but WITHOUT enabling any of the other options on the “typing” tab, such as “Key(s) to change layout”. Wow, I can’t believe I wasted two days trying to accomplish this simple task.

One other comment I’d like to add regarding my original post, is that it’s probably not actually gnupg that’s misbehaving, but the key-management program, seahorse.

It’s worse – well, maybe not because it’s a choice. You can tell seahorse to permanently remember the pass phrase. It is then stored in the Gnome keyring, and automatically made available when you log in (encrypted with your login password).

A major reason that I switched to KDE4, was that I did not like “seahorse”. That was back in the days of Gnome 2.

Yes, more specifically what I was referring to is the behavior one sees after he installs the Nautilus Seahorse extensions. This utility makes the options to “encrypt” and “decrypt” appear on the right-click menu in Nautilus. When one selects a file, then “Rt-Click, encrypt” a window pops up asking for the key, the passphrase and whether you want to make this passphrase automatically available every time you log on - just as you say above. However, even if this option is not selected, Seahorse (apparently) remembers the phrase for the remainder of that session, and will continue to decrypt files without asking for the passphrase again. If I’m not mistaken, it used to be that it became unavailable within a few seconds following use. This behavior may be controlled by a “timeout” setting someplace, but I haven’t yet been able to find one in the configuration.

My relationship with Seahorse has certainly had it’s ups and downs. When it works, and especially when it works with Nautilus, it’s a very useful utility. There have been a number of DI’s however, where it worked poorly or not all with Nautilus and particularly so with Nemo which is/was the Nautilus fork used in some Gnome distros.