Possible BUG with the last KERNEL-FIRMWARE update (Graphic card AMD radeon 7600) (leap 15.5)

On the first reboot after the last kernel-firmware update (packages: kernel-firmware-all-20230724-150500.3.3.1.noarch.rpm and all the other kernel-firmware-…) there was a major glitch with the graphical interface (a message complaining about amdgpu… something) a then GUI freeze in a matter of seconds.
On reboot I tried “safe mode…” from grub menu, but the system crashed again (GUI frozen and same messages as before). On the next reboot it went into “rescue mode” a showed some errors on the root file system: I had to run fsck manually and it found and repair some files but the GUI still isn’t working. After this, to revert to a stable system, I reinstall the system. Unfortunately, I haven’t keep any log of the error, but it was definitely related to a graphical problem (my VGA is a AMD radeon 7600 ).
Afert reinstallation and with all the updates but the last kernel-firmware the system works properly, like before the last update.

I post this report on the forum following the guide to bug report(openSUSE:Submitting bug reports - openSUSE Wiki) where is written "… Non-technical users: You may try first http://forums.opensuse.org . "

It is a pity that you do not have the contents of the error message(s), but I would see you have given proof that this is a regression and that thus a bug report with your above description (also of the hardware) is in place.

And please then post the link to the bug here, so that others that are interested can follow it (and maybe can add what they read from the error message).

Unfortunately, there is no relevant information which would make a good bugreport. No developer or any other tester would be able to recreate the problem. The error messages are necessary to recreate, analyze and debug the problem…

Yesterday I saw a new kernel update available (5.14.21-150500.55.12-default).

I installed it, but keeping the old firmware and it worked.

Then I updated the kernel-firmware packages to the last version (20230724-150500.3.3.1) and it worked.

Therefore, referring to the original title, it was not a bug in the firmware package but probably some kind of incompatibility between the prevoius kenerel(5.14.21-150500.55.7-default) and the latest firmware(20230724-150500.3.3.1).

Now with all the updates in place the system works correctly.

PS: I would like to change the title adding SOLVED or “NO LONGER RELEVANT” but I can’t find a way to do it.

No need. Your last post is fine to convene the message.

And thanks for reporting back the success.