pop mail wont download new messages on one host

I run opensuse 11.0 at home… I have several pop email accounts. I often check my mail in the morning before going to the office. The other day I noticed that at the office (where I too run opensuse 11.0) that new email messages I had seen at home did not show up in thunderbird (the last messages were dated Nov 27th). I always leave the messages on the server so they can be fetched from multiple places. Suspicious that something might be amiss with tbird, I fired up kmail and configured for the pop account. It pulled in all the mail and again, it only showed mail up to Nov 27th. I tried Evolution same thing. Note that this is only happening on one of my two pop accounts. I tried sending some test messages… they wont show up… I can login from a different host and the messages are there. I can also verify the emails are in the mailbox via my domain hosts’ webmail interface. I fired up a VM running windows XP and checked the email there in Outlook express… again the email messages after Nov 27th are absent.

I am totally baffled as to how this issue can happen for one host and not another. Is there a common point of failure that all the email clients would see (including the vmware VM)? I do all the updates and update often…

Does anyone have any ideas?

Any information would be greatly appreciated.

I should have mentioned that I have two pop accounts defined in tbird. This problem only affects one of the accounts. The other account works just fine.

I should upate -

This issue turned out to be that my ISP moved my mailhost to a different server, but the service on the old server was left running, even though no new mail would go there. I had an /etc/hosts entry for the mail server pointing to the old IP… Therefore, when I checked my mail, I was going to the old server and only seeing old messages…