Poor performance on Phoronix Test Suite graphics performace on AMD Radeon Vega Mobile Gfx @ 2.30GHz

AMD Ryzen 7 PRO 3700U w/ Radeon Vega Mobile Gfx @ 2.30GHz
Linux 4.12.14-lp151.28.16-default #1 SMP Wed Sep 18 05:32:19 UTC 2019 (3e458e0) x86_64 x86_64 x86_64 GNU/Linux
The system is a Lenovo T495. I have 24Gbytes of RAM.

The test suite runs the “Heaven” benchmark. I have run it at 1920x1080. No specific benchmark data for my notebook is available, but here is some data on desktop PCs.

I am getting 1 to 2 FPS, and it doesn’t even look that fast. I am using the opensource graphic drivers and do have mesa-3d installed. Before I attempt to install the proprietary drivers, any suggestions?

Too new processor and graphics for a Linux 4.12.
Install new kernel from the Stable repo.

I think you are using graphics that bult in Ryzen 7 PRO 3700U, and not using Radeon Vega Mobile Gfx at all.
Ordinary methods - Bumblebee - works with Intel + Nvidia chips.
You have AMD + AMD.
Consult with Lenovo about Linux support.

AMD+AMD (amdgpu) works out of the box, add switcheroo control to use application for dGPU and/or use DRI_PRIME=1 from the command line.

@OP, no need to install a newer kernel (yet), add the boot kernel option amdgpu.ngg=1 via YaST -. Bootloader and see how that goes first. There are other module options to add to see if it helps.

Also can you post output from;

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

Supposedly OP will need to update Mesa with X11-XOrg repository.
You will need Full repository Vendor change with this repo for a right working update.

And that will help the distribution how? What we need are bug reports if it doesn’t work, else it won’t work with Leap 15.2, 15.3 or 15.4…

Done. Good idea. I know about the full vendor change.

The switch didn’t help though, but might be useful when something else is fixed.

To my surprise, switcheroo is actually a program. I ran it. I doesn’t ask for input. Is that where dGPU and or DRI_PRIME=1 is used?

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
07:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:15d8] (rev d1)
        Subsystem: Lenovo Device [17aa:5125]
07:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:15de]
        Subsystem: Lenovo Device [17aa:5125]

I added the line to the bootloader kernel options. I am not sure if that was done correctly:

resume=/dev/disk/by-uuid/611b9e33-764b-4935-b0d6-1e2da8df74eb quiet amdgpu.ngg=1 

In summary, I need guidance on dGPU or that DRI_PRIME.

In your case you just have the one GPU, so no need for the other stuff. So you need to raise a bug report since the 1002:15d8 is not supported in the kernel (since you have no driver present), see if they will backport (which they should do) for your new device;

openSUSE:Submitting bug reports - openSUSE

Or as indicated run the later stable kernel… which may require the later mesa etc…

Or switch to Tubleweed?

Just to be clear here, was it the switcheroo I don’t need or the additional text on the bootloader?

I am going to try the kernel upgrade.

Before I report a bug, I think I am onto something here. Using Yast, kernel-firmware-amd is not installed. When you try to install it, it requires dracut to upgrade to rev 49. I managed to do that with a RPM. Then trying to install kernel-firmware-amd generated the following:

cat conflicts.txt
#### YaST2 conflicts list - generated 2019-10-01 01:51:41 ####

kernel-firmware-amdgpu-20190909-281.1.noarch conflicts with kernel < 5.3 provided by kernel-default-4.12.14-lp151.28.16.1.x86_64

     ] do not install kernel-firmware-amdgpu-20190909-281.1.noarch

     ] Following actions will be done:
install kernel-default-5.3.1-2.1.g4940602.x86_64 (with vendor change)
  openSUSE  -->  obs://build.opensuse.org/Kernel
deinstallation of kernel-default-4.12.14-lp151.28.16.1.x86_64
install kernel-default-5.3.1-2.1.g4940602.x86_64 (with vendor change)
  openSUSE  -->  obs://build.opensuse.org/Kernel
deinstallation of kernel-default-4.12.14-lp151.28.13.1.x86_64
deinstallation of r8168-kmp-default-8.047.01_k4.12.14_lp151.28.16-lp151.3.10.x86_64
deinstallation of broadcom-wl-kmp-default-
deinstallation of rtl8821ce_bt-kmp-default-1_k4.12.14_lp151.27-lp151.34.1.x86_64
deinstallation of r8168-blacklist-r8169-8.047.01-lp151.3.10.x86_64
deinstallation of broadcom-wl-

I didn’t make the changes. Since Leap 15.1 will hold multiple kernels, I assume the old 4.12 will be there in the boot menu. I altered the config to hold latest-2 and oldest.

I cloned the hard drive just to be safe then did the kernel upgrade. The frames per second is now 15 rather than one.

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
07:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:15d8] (rev d1)
        Subsystem: Lenovo Device [17aa:5125]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

Progress :slight_smile: So now with the later kernel if you run the command;

systool -vm amdgpu

Is the ngg parameter 1 or 0? if 0 try the boot option amdgpu.ngg=1 and see if it helps.

Output with this command can be helpful:

inxi -Gxxx

It was already a 1. I already had that parameter on the boot loader. Is it worth trying a 0? (I am always paranoid about not being able to boot.)

inxi -Gxxx
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 15d8 bus-ID: 07:00.0 chip-ID: 1002:15d8
           Display Server: x11 (X.Org 1.20.5 ) drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: AMD RAVEN (DRM 3.34.0, 5.4.0-rc1-1.g6fce476-default, LLVM 7.0.1)
           version: 4.5 Mesa 19.2.0 Direct Render: Yes

If it was, no need to change. I would suggest booting from a Tumbleweed Live USB and see if FPS improves (you can install on the live USB anything you need) as it will have the latest Mesa etc.



and look at inxi’s version.
Looks like you need to update inxi to a version 3.0+.
You can install it with a https://software.opensuse.org/package/inxi?search_term=inxi .

drivers: ati,amdgpu

IMO - you need only amdgpu, blacklist ati.

OpenGL: renderer: AMD RAVEN

Supposedly you are using GPU built in processor.
So it is worth trying a 0.

There is only one GPU present in the system, it needs to be 1 for the card since it’s next generation, which it’s automatically detecting.

I could boot Tumbleweed live and I guess I would download the benchmark. I will put it on the list.

BTW I only have two kernels saved even after doing the mods to the conf to save more. And both kernels are rev 5. Go figure. I have to see if that is a bug or pilot error.

I’m going to put in a small SSD I have that came with the notebook and do a full installation of Tumbleweed rather than use the live version. Check back in a week.