Poor performance in VMware Fusion

I have been experimenting with Tumbleweed the past few days in VMware Fusion 8.1.0 on my Macbook Pro.

I’ve noticed extremely poor performance, seemingly disk related. I’ve ruled out filesystem type (tried both btrfs and ext4) and disk driver (tried SATA and SCSI).

I don’t see the same behavior in Veertu (which is a new hypervisor for the Mac) or KVM in our private cloud.

Is this a known issue, and is there a fix or workaround? A search of the forum archives didn’t show anything.



Depending on what you’re doing,
You may need to consider your disk block and/or partition alignment. I posted about this in a Forums thread

Most apps don’t hit the disk often enough for disk performance is an issue, but if you’re extensively reading data from disk you may want to better understand how your physical disk blocks are arranged and the logical blocks on top of them.

You might find a few other virtualization and VMware articles I’ve written useful on my Wiki pages…


Did you install the VMWare Tools? This solved such problems for me on different file systems.


Whenever you install any version of openSUSE in a virtual environment (including VMware), Guest Tools (or its equivalent if virtualization is something other than VMware) is automatically installed.

So, unless you’ve done something like execute a P2V you should already have Tools installed.

As for the Tools version, prior to approx Apr 2015, the official releases of VMware Tools were kernel and VMware version specific. Although recent Tools <should> work regardless of kernel or VMware app version, that can’t always be guaranteed, and latest Tools releases might contain improvements. If you suspect your Tools (or anything else in your system) is not up to date, do a system update with the following command in a root console

zypper update

If that doesn’t solve your problem and you still suspect a Tools issue, you can install the latest VMware tools released from VMware. Since you’re running TW, you have to install the package providing legacy tools before you can run the scripts that update the latest from VMware

zypper in net-tools-deprecated

Instructions for updating VMware Tools to latest from VMware (all versions openSUSE)
Then, either clone the following github repo (You can download the TAR or ZIP and unpack, but it’s less advisable since cloning the github repo gives you a source which can always be updated easily with a “git pull”)
Execute the following commands which are at the top of the documentation for the repo

$ git clone https://github.com/rasa/vmware-tools-patches.git
$ cd vmware-tools-patches 
$ ./patched-open-vm-tools.sh


I’m confused, because I’m sure I responded to this thread yesterday, but my post isn’t here–maybe I only clicked ‘preview’.

I figured this out, it turned out to be a DNS resolution issue. For some reason leaving ‘search localdomain’ in resolv.conf generates some slowness. I’m not sure if it’s because isn’t mapped to ‘localhost.localdomain’ in /etc/hosts by default, or whatever, but taking it out fixes the performance issue.

Good to hear you resolved your issue.