Poor 3d performance when composite is on

Hello to you all :wink:

I have a 3d performance problem on my 11.1 32bit athlon xp2800 machine, with kde4 factory repo and nvidia fx6600gt.
The problem occurred after an kde update that I did about 15 days ago.

When I enable composite I experience poor 3d performance (2-3fps in glxgears), thus with composite off, 3d performance is just fine.

Before the update (which I can’t exactly remember which day it was) everything worked fine with composite on and desktop effects fully enabled.
Now I can enable desktop effects but I get tragic performance and can’t use 3d applications like googlearth for example.

I’m using 180.29 driver from the nvidia repo, and my xorg.conf is the following.
Any ideas will be highly appreciated, thanks in advance!

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Thu Feb  5 00:18:17 PST 2009

# /.../
# SaX generated X11 config file
# Created on: 2009-02-21T14:28:55+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
    Identifier     "Layout[all]"
    Screen         "Screen[0]" 0 0
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Mouse[1]" "CorePointer"
    Option         "Clone" "off"
    Option         "Xinerama" "off"
EndSection

Section "Files"
    InputDevices      "/dev/gpmdata"
    InputDevices      "/dev/input/mice"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/local"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/URW"
    FontPath        "/usr/share/fonts/Speedo"
    FontPath        "/usr/share/fonts/PEX"
    FontPath        "/usr/share/fonts/cyrillic"
    FontPath        "/usr/share/fonts/latin2/misc:unscaled"
    FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/Type1"
    FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath        "/usr/share/fonts/baekmuk:unscaled"
    FontPath        "/usr/share/fonts/japanese:unscaled"
    FontPath        "/usr/share/fonts/kwintv"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/uni:unscaled"
    FontPath        "/usr/share/fonts/CID"
    FontPath        "/usr/share/fonts/ucs/misc:unscaled"
    FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/misc:unscaled"
    FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/Type1"
    FontPath        "/usr/share/fonts/misc/sgi:unscaled"
    FontPath        "/usr/share/fonts/xtest"
    FontPath        "/opt/kde3/share/fonts"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "AllowMouseOpenFail" "on"
    Option         "ZapWarning" "on"
EndSection

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbLayout" "gb,gr"
    Option         "XkbModel" "microsoftpro"
    Option         "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
    Option         "XkbRules" "xfree86"
    Option         "XkbVariant" "basic,extended"
EndSection

Section "InputDevice"
    Identifier     "Mouse[1]"
    Driver         "mouse"
    Option         "Buttons" "9"
    Option         "Device" "/dev/input/mice"
    Option         "Name" "ImExPS/2 Generic Explorer Mouse"
    Option         "Protocol" "explorerps/2"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Modes"
    Identifier         "Modes[0]"
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "--> VESA"
    ModelName      "1280X1024@60HZ"
    UseModes       "Modes[0]"
    DisplaySize     305    230
    HorizSync       31.0 - 64.0
    VertRefresh     50.0 - 60.0
    Option         "CalcAlgorithm" "XServerPool"
    Option         "PreferredMode" "1280x1024"
EndSection

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVidia"
    BoardName      "GeForce 6600/GeForce 6600 GT"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "on"
EndSection

Since you haven’t got an answer yet, I’ll try…

I remember reading in this forum about a setting in xorg.conf related to acceleration. Some driver/nvidia hardware combinations require that you set option xaa (X acceleration architecture) instead of the default nvidia acceleration achitecture. If you search the forum you’ll certainly find it.

Mind you, I’m quoting from memory, some details may/will be wrong.

Good luck.

Oops, faulty memory. It seems this xaa x exa issue is related to intel GMA, not nvidia. Something else you could look into is if your card is set to ‘sync to vblank’ and change it.

I’ve already tried that , no luck. Thanks anyway!

I removed the 180.29 driver (which is on the nvidia repository), installed the 180.37 from nvidia’s ftp site and everything is running fine until now.

So I guess it was an nvidia driver issue :wink: