Podman-systemd.service and quadlets?

Hello!

I am running MicroOs (the tumbleweed one, not leap) and I have been having some issues with the podman restart service (it fails on container relationships such as --requires). I decided to convert my current spaghetti to systemd units in “quadlet” form.

For some reason I can’t get them to start. In the podman documentation on my system I find podman-systemd.unit (‘man quadlet’ works as well).

I tried putting .container and .pod files in the directories mentioned in the documentation, but they do not show up after ‘systemctl daemon-reload’ nor after a reboot. Nor can I find any unit named podman-systemd.unit.

The system is up to date and runs podman 5.0.x.

In have tried:

  • placing .container files in the directories specified in the podman-systemd.unit man-file. Both user and system.
  • looking around for the above unit file
  • doing a daemon-reload
  • searching in zypper for extra podman packages.

Does anyone have any clues?

Best regards
Linus

I figured it out. I had used a field not supported and there were no logs to tell me what was wrong.

I figured out by running the podman generator manually

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.