Plymouth openSUSE 13.2 broken

I think I broke plymouth, I was trying to debug why my AMD card fails at suspending, so I read somewhere that I should edit
/etc/suspend.conf like this in order to get more verbose output:


loglevel = 255
splash = n

After that my plymouth splash was replaced with a black screen, so I changed back to "splash = y", rebooted but still a black screen.

So I ran:


sudo plymouth-set-default-theme -R openSUSE

Without success again.

The I ran with this posts:
https://www.reddit.com/r/openSUSE/comments/33b7p5/plymouth_never_works_on_opensuse_these_days/
https://www.reddit.com/r/openSUSE/comments/31mlvu/plymouth_is_broken_in_tumbleweed/
Those basically explain this is not a plymouth issue, the 2nd post says I should edit the** /etc/sysconfig/kernel** file adding:

INITRD_MODULES=$driver

and the run mkinitrd

But, what driver/module should I put here? the explanation says it should be an KMS video driver, I’m using the proprietary AMD one (fglrx)

Sorry can’t help but I would like to gently point out for the future that any time you make a change to a config file always make a backup first. In fact many editors do make backups often named the same but ending in a ~ character. You might check.

Those two lines were commented so I commented them again, I don’t think that a backup was necessary (just two lines!), and I do backup :wink:

suspend is not used at all by default any more, and in 13.2 it even does not support any splash at all.
Still, try to comment out both options, by adding a ‘#’ at the beginning of the lines.

You could try to uninstall pm-utils too though, maybe that helps.

After that my plymouth splash was replaced with a black screen, so I changed back to "splash = y", rebooted but still a black screen.

You mean the splash screen during boot?
/etc/suspend.conf should have no influence at all on that.

So I ran:

sudo plymouth-set-default-theme -R openSUSE

Without success again.

Do you actually have plymouth-branding-openSUSE installed?

The I ran with this posts:
Reddit - Dive into anything
Reddit - Dive into anything
Those basically explain this is not a plymouth issue, the 2nd post says I should edit the** /etc/sysconfig/kernel** file adding:

INITRD_MODULES=$driver

and the run mkinitrd

Those posts are are about Tumbleweed.
Also, they talk about seeing the text mode plymouth screen (i.e. 3 dots, or 3 question marks), not a completely blank screen.

But, what driver/module should I put here? the explanation says it should be an KMS video driver, I’m using the proprietary AMD one (fglrx)

In that case, none.
You could try fglrx, but I have no idea whether that works.

When I say backup I mean make a copy of the file you don’t have to go to the trouble of doing a full backup. It allows one to return to a known good state without having to remember all the changes. Just copy the file to a file called thefilename.bak

suspend is not used at all by default any more, and in 13.2 it even does not support any splash at all.
Still, try to comment out both options, by adding a ‘#’ at the beginning of the lines.

Got it, I did commented back those lines :wink:

Do you actually have plymouth-branding-openSUSE installed?

I do, and also the Plymouth splash was working just fine.

Those posts are are about Tumbleweed.
Also, they talk about seeing the text mode plymouth screen (i.e. 3 dots, or 3 question marks), not a completely blank screen.

Yes, but I though they may help, here’s some other post I found:

https://forums.opensuse.org/showthread.php/478013-openSUSE-12-2-No-Plymouth!/page2

Yes I understood, thanks for the help. I sometimes rename files like <filename>.old

Try to reinstall it.
Also, try to run “sudo mkinitrd”. I’m not sure whether plymouth-set-default-theme actually does anything if you set the same theme that’s already set.

And please clarify:
You see a completely black screen, right? No text messages or similar?
Does pressing ESC have any effect?

You’re not using plymouth.enable=0 or similar on the kernel command line?

cat /proc/cmdline

Yes, but I though they may help, here’s some other post I found:

Rather not.
It’s something completely different whether plymouth falls back to text mode (because it cannot load the graphics driver), or it displays a black screen.

openSUSE 12.2 - No Plymouth! - Install/Boot/Login - openSUSE Forums

In this case, the problem is distorted graphics.
Another completely different case than yours.

Maybe this would help, I forgot to mention that:

# plymouthd; plymouth --show-splash

Works!

Try to reinstall it.
Also, try to run “sudo mkinitrd”. I’m not sure whether plymouth-set-default-theme actually does anything if you set the same theme that’s already set.

And please clarify:
You see a completely black screen, right? No text messages or similar?
Does pressing ESC have any effect?

I had reinstalled it with no effect but after that I ran **sudo plymouth-set-default-theme -R openSUSE **instead mkinitrd (but I think the first command also runs mkinitrd).

I see a black screen during the time (aprox.) it should be the splash screen, then I see the boot log and then the login screen.

You’re not using plymouth.enable=0 or similar on the kernel command line?

Nope.

cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-3.16.7-24-desktop root=UUID=943877e9-d004-46d3-948a-82f61a18fef3 resume=/dev/disk/by-uuid/98d7a462-74e6-4d1e-ba15-73d49eb6e2c3 splash=silent quiet showopts elevator=deadline libata.force=noncq acpi_sleep=s3_bios

I reinstalled:

plymouth-plugin-script
plymouth-scripts
plymouth-branding-openSUSE
plymouth
plymouth-dracut

and then ran:

sudo mkinitrd
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

and still had a black screen.

On 2015-09-12 02:46, itaranto7 wrote:

> Code:
> --------------------
> cat /proc/cmdline
> BOOT_IMAGE=/boot/vmlinuz-3.16.7-24-desktop root=UUID=943877e9-d004-46d3-948a-82f61a18fef3 resume=/dev/disk/by-uuid/98d7a462-74e6-4d1e-ba15-73d49eb6e2c3 splash=silent quiet showopts elevator=deadline libata.force=noncq acpi_sleep=s3_bios
> --------------------

You are using some non default options: “elevator=deadline
libata.force=noncq acpi_sleep=s3_bios”. Why? :-?
Maybe to solve your initial problem with suspend?


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Just to be sure - do you see GRUB boot menu? What exactly “boot log” is - is it kernel output, is it output of services that are starting? Do you have normal 80x25 text console at this point or is it frame buffer (which usually has more lines/columns)?

elevator=deadline is a good scheduler for SSDs.
I have to use libata.force=noncq with my Samsung EVO 840 SSD otherwise I got a lot of CRC errors.
Yes I was trying to debug why my AMD card doesn’t work when suspending to RAM. I guess I can remove acpi_sleep=s3_bios (because it didn’t work).

GRUB2 menu shows up fine, the boot log is the list of the services starting (the same you see when you do: cat /var/log/boot.log). I see this in a “graphical” way, I mean is not the 80x25 text console.

I found that running **plymouthd; plymouth --show-splash **works from a text console.

I Finally solved it!!!
The file /etc/plymouth/plymouthd.conf contains

[Daemon]
Theme=openSUSE

but there’s another file called /etc/plymouth/plymouthd.conf.rpmnew, this is the default configuration when you reinstall plymouth, and it has:

# Distribution defaults. Changes to this file will get overwritten during
# upgrades.
[Daemon]
Theme=openSUSE
ShowDelay=5

So I added the delay line into /etc/plymouth/plymouthd.conf, however this didn’t work either, so I modified like ShowDelay=0 and now the splash is back!
Thank you all for helping me out!

I have the same problem on two PCs (one desktop and one laptop) running Tumbleweed.
I looked at the whole thread, tried all given solutions/workarounds but I still see the black screen when the plymouth splash should be shown.

Any thoughts? Anybody else having this issue?

Cris