Plug Mic is not detected 13.2

Heya,

Having problem - mic is not detected in earplugs with mic. After the pluggin of the headphones it detects headphones but uses laptop mic( headphones mic os not detected). Tried this with different plugs.

Opensuse 13.2, Laptop: Asus Infinity ux301la-de056h, http://www.alsa-project.org/db/?f=992a6d98fc7510b340d5c1422c11f10cdc437f7b

Can anyone assist me with this?

Thank you!

Are you plugging the mic plug from the headset in also??

Are you using pavulcontrol to see the devices?

It is combined jack. When I plug it in pavucontrol shows that laptop speakers become unavailable and headphones are plugged instead - that’s correct. But Input Device tab shows no changes - laptop mic is still there and plugged mic is not detected. Tried it with different sets of plugs.

Did you run a record application to see if it then shows up ? My experience is with some devices pavucontrol will only show the record mic when the recording application starts.

I’ve tried skype. Nothing happened.

What do you mean “nothing happened”??

Did you run pavucontrol at the same time? Did you initiates a test call? How is the audio configured in Skype?

In skype audio configured via pulseaudio. Mic does not appear. Tried it with 2 different plugs. When plugs are plugged laptop mic and earplugs are working. So it sees plugs but doesn’t see mic.

I expect that the odd hardware having earplug and mic combined is the problem to be honest I have never seen such an animal. :open_mouth:

Can you point to documentation of this odd setup??

If I launch Skype, and then launch pavucontrol, I see no indication of a Mic in pavucontrol. This is as expected. It is only after I initiate a TEST CALL with Skype (and during that call) that I will see the mic show up in the pavucontrol record tab. The instant the call is finished, the mic will disappear from pavucontrol.

I read and reread your post a few times, and I can not tell if that is what you did. Instead I read some comment about plugs, but I have no idea what you mean by that. Are you comparing external mic to an internal mic ?

I had pavucontrol running and earplugs with mic plugged in. pavucontrol shown plugged headphones and didn’t show plugged mic. I’ve tried skype call. Plugged microphone did not appear in the list of devices in pavucontrol not before call not during the call, laptop mic was active and it was the only mic on list of pavucontrol (headphones were detected fine). Same set of plugs works with my cell as expected.

A cell phone is not the same as a PC. All PC sound cards I have ever seen have a separate output and input plugs. The are not combined. The output is most often sterio so it does support two channels but both of them out. I have never seen any PC that has a combination of mic and earphones in one plug. Not say there never has been but they must be as scarce as hens teeth.

It’s laptop. Laptop usually have combined jack.

Funny mine does not

In over 18 years, I have never owned a laptop that did not have a separate jack for mic and for headphones out. Usually laptops have separate jacks.

Have you ever had this working with another OS on same laptop ?

I looks to me from the alsa-info script output that there is only one mic reported by alsa:


ARECORD

**** List of CAPTURE Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC3229 Analog [ALC3229 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

and based on the description you gave, I assume that is NOT the mic input you are attempting to use ? … or did I read your description wrong ?

Me neither, but I did quickly check the specs ASUS_ZENBOOK_UX301LA specifications and it does indeed have a combined jack (like many phones do)

Interface1 x Microphone-in/Headphone-out jack
2 x USB 3.0 port(s)
1 x micro HDMI
1 x mini Display Port

However, even being combined in same jack, I would still expect it behave the same way internally.

After a little more searching, I’ve turned up a few threads that suggest so-called combo jacks can be ‘re-tasked’ by alsa, and that ‘alsa-tools’ contains a utility (hda-jack-retask) for this.

Examples:
http://voices.canonical.com/david.henningsson/2011/11/29/turn-your-mic-jack-into-a-headphone-jack/
https://bbs.archlinux.org/viewtopic.php?id=185206

Maybe this could help with explicitly assigning the required function, (although I would have assumed a mic would automatically be detected by it’s impedance once plugged in).

Now, when I installed alsa-tools (1.0.27 for openSUSE 13.1), although the utility is mentioned in the README, it didn’t appear to include the actual utility. (This might be different for openSUSE 13.2 and Tumbleweed packages.)

That is educational. Thanks.

I note: openSUSE Software

I also see it available in YaST on openSUSE-13.2, but not automatically installed.

I would think care is needed when using this app such that one does not break their mic/sound config when trying to setup.

Here is an older thread on hdajackretask: https://forums.opensuse.org/showthread.php/497421-Beats-Audio

Note post#19 gives the users method/settings.

I think you meant post #8 (the user had 19 posts). Strange… I did search for ‘hdajackrestask’ but couldn’t find it initially. I’ve never had need for it, but could be relevant here.