Plex clients will not connect to the server without disabling the firewall even after ports have been added

So the strange thing is even after adding all the ports used by Plex to my zone in Firewalld, clients (in this case a smart tv & an android tv box) cannot connect to play a movie. However they can authenticate as I am logged into the clients and they know the servername, but for some reason they cannot communicate with the server to play a movie.
If I turn the firewall off completely then the client will work with no problems. Below is the ports entered according to the Plex website.

Can anyone offer any assistance on this?



I’ve now found out what was happening (I think) by using the debug command on Firewalld. My zone for the interface was being reset automatically to ‘Public’ even though it was set in YAST to be ‘Home’. Apparently the settings in NetworkManager override the settings in YAST and the firewalld config files. Lucky I stumbled across that one.
NetworkManger was set mistakenly to use ‘Public’ for my wifi rather than ‘Home’. Might be sensible for a laptop but this is a PC. Using ‘firewall-config’ picked this up and allowed the change to be made. Presumably I could have changed this in Networkmanager as well.

Hopefully this may help someone else.