Please Supply Config FIle, Won't boot.

Hi I’m new resonably new to linux. I have previously had a dual boot on this computer with windows and openSuSE 10.2 a couple of years ago. Ive been Having trouble installing 11 though can someone please help!!!

I downloaded the OpenSuSE 11 dvd did a md5 checksum, burnt it to disc at 8x made nero do a disc verification after burning, booted the disc up checked the media all that was fine.

Then I tried to install linux as soon as i hit install it entered a text screen and said;

“Probing EDD (edd=off to disable)…ok
Undefined video mode number 31a
Press <ENTER> to see video modes available, <SPACE> to continue, or wait 30 sec”

I have tried all the of them and they all end up with it loading basic drivers i think it does a hardware detect and loads drivers. it will eventualy end up saying something like;

“Probing connected terminal
‘found linux terminal at|in /dev/console’
Initilizing virtual console
Please supply a config file”

All this happens within a couple of seconds so some of it mightnt be 100% accurate. After it displays the “Please Supply A Config File” my screen basically goes blank and my monitor goes into power saving, I believe my video card stops giving out an output. Nothing responds, I can remove the dvd from my tray and i have to reset it to do anything. I have also left it for over an hour without any luck.

Any help would be appreciated as I really would like to install OpenSuSE on my system.

Try installing SuSE in textmode by hitting F3 (← key might have changed meanwhile, choose adding boot-parameters) and type


That’s not as good-looking as the GUI-install, but YaST should recognize your complete hardware during the initial install and then be able to kick the X-server into gear.

Boot from the DVD and in the Boot Options below on the menu, type this:


@mingus725: That solution seems pretty special to me… any explanations?

the edd=off option worked thanks a million, um yeah i also tried text mode i think it was esc and im pretty sure it ended up in the same place.

Now with that edd=off do i need to put that in my boot codes for my installed opensuse bootloader?

If so how do i do that?

Thank you so much mate ive been really desperate to get opensuse back up and running. lol i have a lot to learn.

EDD = BIOS Enhanced Disk Drive Services. It’s a mechanism to match BIOS device names (e.g. int13 device 80h) to Linux device names (e.g. /dev/sda, /dev/hda). The code makes BIOS calls very early during kernel startup to obtain the Master Boot Record signature and physical location of BIOS-seen disks, then exports this information through sysfs.

Unfortunately, not all BIOS’s implement EDD, some do not do so consistently or completely. Bios’s older than a few years will not have it at all. edd=off disables the kernel probe for the edd map.

@eevee, if you have not installed yet, just add it to the installation menu Boot Options and it will carry through to be added to the kernel line in your boot stanza in the grub menu.lst control file. Otherwise it can be added via YaST Boot Loader or simply editing /boot/grub/menu.lst as root.

Thank you for the explanation!

Thanks Heaps mate.:slight_smile:

Thanks a lot, this worked for me, too.

You’re quite welcome, to all. :slight_smile:

Following this thread it seems that using the edd=off option works for those using a DVD. I’m trying to use a livecd (KDE4/11.0) and was getting the “Probing EDD (edd=off to disable)” message. When I put the edd=off in the boot options I don’t get the error message anymore, it simply dies, nothing more happens, no attempts to read the cd and a blank screen. Any ideas?

While a problem with the edd probe can disrupt the framebuffer driver which displays the graphical bootsplash screen and nice text, it doesn’t usually prevent the desktop gui from loading later (because the CD runs an X server with a different driver). When you try to run it normally (without disabling edd), does it fail to load? Watching the scrolling text, do you see what it fails on? What happens if you switch to “text mode” (the F3 key)? Did you try booting it with “Failsafe”?

By the way, this edd behavior can be erratic. I have a machine where the edd probe unexpectedly failed, continued to do so for a time, and then starting working - and absolutely nothing had changed. As I posted before, edd implementations in the bios are sometimes flakey. One trick to try before booting: Turn off the machine, remove the power cord, gently depress the power on button for ten seconds, reconnect the cord and power on; this will remove any residual electrostatic charge in the machine and insure that memory is entirely flushed, insuring starting with a clean slate.

Have tried many configurations:

Standard - Get probing edd, etc error
Failsafe - Machine hangs, screen goes blank, nothing happens
Setting edd=off - machine hangs, screen goes blank, nothing happens
Textmode - Get probing edd, etc error

Machine is a Compaq EVO D300v, one of several types of machines we will test before deploying for production. We are having no problems installing on Compaq D530’s and several models of laptops other than the known bugs still in the system. The D300v seems to the only machine type we have problems with.

Does it lock up on the probing? If so, try entering the following in the Boot Options:




Is using the DVD an option?