*Please read. Must have Live USB connected in order for OpenSuSe leap to work *properly*

Dear Friends,

I am in need of help.
I have a lenovo R400 laptop that has Windows 7 Pro. OS. I decided to partition my hard drive in order to install and use OpenSuSe. I wanted to install 13.2 but I was unable to find the 13.2 download and consequently downloaded Leap onto my live USB and then Installed Leap to my computer. Everything was going smoothly and I had a close computer savvy friend help partition my hard drive during the “Partitioning” part of the installation. I successfully installed leap (I thought I did) onto my laptop. After playing around with the OS, I discovered that when my live usb was not plugged I was immediate limited to certain things. These certain things to my knowledge have been for instance, when trying to download google chrome when the live usb was not plugged in, I would get an error a long the lines of “empty destination” and then some long folder name and some numbers trailing. Another issue I noticed that was not working properly was updates. My computer would display messages of updates but would say “Update Error, cannot find file.” Also, I just recently discovered that when I plug another monitor into the port of my laptop, without the live usb connected it does not properly work. All of the above malfunctions were fixed as soon as I inserted my Live usb. Now my usb is an external 500 gb drive so I would love to erase leap from the device so I could put other items on the usb. In short, I do not want to have to have the live usb inserted at all times in order for the OS OpenSuSe Leap to work. I would very much appreciate feedback and guidance to this problem as I know it can be fixed. Note, I have tried reinstalling multiple times.

Likely you wrote the bootloader to the USB

Boot the system
Open a terminal and do

su -
grub2-mkconfig -o /boot/grub2/grub.cfg

grub2-install /dev/sda

Remove the USB and try booting

I disagree with caf4926’s analysis of your problem.

I suspect that your only problem is that the install USB is still listed as an active repo.

So, here’s what to do:

Yast → Software Repositories

Find the line for your USB. It probably has “openSUSE-42.1-0” in the name field, and the URL field begins with “hd:///”.

Select that line. Then click “delete” toward the bottom left of the screen.

That should remove all references to your USB drive.

If you want to play it safe, then instead of “delete”, just uncheck the “enabled” box.

Then click “OK” near the bottom right.

Perhaps you will then want to test to see if things work without that USB drive plugged in.

I agree

Please disregard my earlier comment. I obviously didn’t read your question thoroughly.

Thank you both very much!! I will try the instructions provided and report back.

Just checking back in. Thank you for your support. As of now it has fixed the problems that were occurring. I do however have a new problem and question. The problem has to do with dual monitors. The other day I found a HP L1908w monitor and I had the idea to hook it up to my laptop so I could have dual screens. Initially, it worked perfectly. My laptop screen had presented the original desktop i.e. Icons, toolbar etc. and the monitor was an “extra” space that allowed me to drag browser to and from. Now my laptop screen goes black and the HP monitor takes over but rarely works properly. It usually freezes up and the toolbar will continuously malfunction. At which point I have to restart my computer and go back to just using my laptop display. I have tried a few trouble shooting techniques, none of which have been successful. Any ideas would be greatly appreciated.

Thanks again,
Fellow friend.

I recommend that you start a new thread for this, including a descriptive title to catch the attention of those who might be able to help you.