Please help to reproduce LibreOffice bug

There is LibreOffice bug https://bugs.documentfoundation.org/show_bug.cgi?id=119044 that seems to be reproducible in openSUSE, but not to be reproducible in Windows or Arch Linux.
Please help to reproduce, confirm and investigate this!

Steps:

  1. Download latest LibreOffice RPMs bundle master*_Linux_x86-64_rpm.tar.gz from https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/current/ and extract RPMs
  2. Install at least libreofficedev6.3-writer libreofficedev6.3-en-US libreofficedev6.3 packages with their dependencies. To do this from command line with dependencies:
URL="https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/current/master~2019-05-04_04.44.35_LibreOfficeDev_6.3.0.0.alpha0_Linux_x86-64_rpm.tar.gz"
TAR="${URL##*/}"
mkdir LibreOffice-master
cd LibreOffice-master
wget "$URL"
tar -xf $TAR
cd ./LibreOfficeDev_*_rpm/RPMS
sudo zypper --no-gpg-checks --non-interactive in --force libreofficedev6.3-writer-6.3.*.rpm libreofficedev6.3-en-US-6.3.*.rpm libreofficedev6.3-6.3.*.rpm libreofficedev6.3-ure-6.3.*.rpm  lodevbasis6.3-core-6.3.*.rpm lodevbasis6.3-en-US-6.3.*.rpm lodevbasis6.3-writer-6.3.*.rpm lodevbasis6.3-images-6.3.*.rpm lodevbasis6.3-*-integration-6.3.*.rpm

Finally open ODT file http://bugs.documentfoundation.org/attachment.cgi?id=144165 . You can do in by executing:

/opt/libreofficedev6.3/program/swriter http://bugs.documentfoundation.org/attachment.cgi?id=144165

Capture you screen. Compare your screenshot with https://bug-attachments.documentfoundation.org/attachment.cgi?id=151200 and https://bug-attachments.documentfoundation.org/attachment.cgi?id=143901
**
Look if you see** “=in equation. LibreOffice 6.0 seems to have = symbol, but 6.1 and later versions don’t.

https://bug-attachments.documentfoundation.org/attachment.cgi?id=143901

https://bug-attachments.documentfoundation.org/attachment.cgi?id=151200

You apparently try to lure others into installing and testing a version of LibreOffice that is newer then the one currently supported on openSUSE15.0 (well, that is the version this thread is created for). But you do not explain why you do not do that yourself. :question:

With LibreOffice version 6.1.3.2-lp150.2.6.2 from the openSUSE Leap 15.0 update repository <http://download.opensuse.org/update/leap/15.0/oss>, I can not reproduce this issue.

  • Tried “=” in text – OK – also in PDF.
  • Tried “==” in text – OK – also in PDF.
  • “===” or “====” in text produces a horizontal page width divider – also OK – also in PDF.
  • Various mathematical formulae – including your example – all OK – also in PDF …

[HR][/HR]Possibly an issue with the version 6.1.0.2 you have.
The newest version of LibreOffice available (for Tumbleweed and Leap 15.0 and Leap 15.1) in the openSUSE repositories «tested with openQA» is: 6.2.3.2.

  • What happens if install the version 6.2.3.2 LibreOffice from the openSUSE Build Service?

<https://build.opensuse.org/package/show/LibreOffice%3A6.2/libreoffice>
<http://download.opensuse.org/repositories/LibreOffice:/6.2/openSUSE_Leap_15.0/>

+1 The current 6.1.3.2 works OK here too.

Thanks for testers!

Problem found: OpenSymbol font (/opt/libreofficedev6.3/share/fonts/truetype/opens___.ttf file) was missing. Fixed by installing lodevbasis6.3-ooofonts package.

We can now close this thread.


 > rpm --query --whatprovides /usr/lib64/libreoffice/share/fonts/truetype/opens___.ttf
libreoffice-6.1.3.2-lp150.2.6.2.x86_64
 > 

Therefore, the openSUSE package doesn’t have this issue …