Please help - no sound from ALC887-VD

Ok I admit it. I am a noob to linux. After many many years, I finally put on the big boy pants, kicked off the training wheels and set off to explore the linux world. I am having a great time with OpenSuse. I have met several hurdles/learning curves and was able to get by all of them on my own. Unfortunately, this sound issue has me at a loss. I have tried just about everything I could. I fear I may I have made it worse. (Though thats hard to tell since broken is broken no matter how much I have jacked it up).

With that, I am asking the community’s support in helping me figure out what I am doing wrong. Any ideas to resolve this are appreciated. For the record, this is not a dual boot system or a VM. Its a new box I built for the express purpose of installing OpenSuse 13.1. So if anything, I am committed or at least should be :slight_smile:

Thanks for any suggestions!

Ok We have no idea what you have or have not done. We were distracted and were not watching over you shoulder

So first off be sure the sound volume is not turned down or muted . You would be surprised how many times this is the problem :wink:

Then go to Yast -sound and see if the driver is active maybe run the test sound

Still no sound? try turn off pulse there is an option in Yast sound for that

You did not say What desktop. There are adjustments for the sound in most. Details depend on the desktop used

If the problem is that some codecs don’t play you need to install the proprietary codecs

please read the sticky here

As you can see, troubleshooting advice is easier to give with the benefit of information. While we’re not trying to be
too picky, all we have to go on (in addition to the title) is:

On 2014-03-12, js4n <> wrote:
> For the record, this is not a dual boot system or a VM. Its a new box I
> built for the express purpose of installing OpenSuse 13.1.

  • in other words all we really have have here is: openSUSE 13.1 and no sound.

So, let’s ask:

  1. Which desktop environment do you have (KDE or GNOME)?
  2. You say you have no sound, but when? All the time (i.e. not even log-in sounds)?
  3. If you go to YaST ->Sound->Other->Play test sound - you still hear nothing?
  4. What devices are listed under YaST->Sound?
  5. (And I appeciate you might not know the answer) - do you have PulseAudio enabled?

Thanks for the responses. I am sorry it took so long to respond. I messed it up good and ended up rebuilding. So back to square 1.

This is on KDE desktop.
There is no sound at all. No system sounds, no music, video,…nothing
I verified that nothing is muted.
I made sure the onboard sound is set as card 0
I have tried disabling Pulse through Yast…and enabling
I installed pavucontrol.
installed alsa pulse plugin 32bit.
verified in alsamixer nothing muted as well.
I have tried the different methods to test sound through yast and CLI.
Removed all pulse (learning experience…boy did that do a number on the system)
I disabled the onboard sound and installed a SB X-FI card. (rinse repeat all above and still no sound)
I ran test sounds and plugged speakers into each jack to see if there was any sound.(Those were logitec x-530 speakers)
Also checked each jack with headphones as well as the front panel headphone jack.
I tried the same with another pair of plain jane dell speakers.
The drivers are active.
There are two Sound devices…

  1. SBx00 Azalia (Intel HDA)
  2. ATI Audio Device…this is the HDMI port on the back of the video card

Looked at the 50-sound file. No idea what I was looking at but it doesn’t have any info like model = 3stack etc…

Thats pretty much it. I am open to any suggestions. Other than this the machine is working well.

Lastly in case it matters, Motherboard is ASUS M5 A97 LE R2.0 with AMD FX-8350 CPU.


Got this from a Ubuntu user maybe it might work

nano /etc/asound.conf

past the following into the file
defaults.ctl.card 1
defaults.pcm.card 1
defaults.timer.card 1

reboot system and your sound should work. Make sure your master volume and your speaker volume are turned up. Hope it helps you out!

Note I’m not sure nano is default installed any more so use the text editor of choice. Also you need to be root

Thanks for that information. Could you provide a bit more please, … connect your PC to the internet and in a terminal/konsole run this diagnostic script (which with the SHARE/UPLOAD option selected) which will upload your PC’s audio configuration information to a URL/web address that you can share:


and please select the SHARE/UPLOAD option, and then let the script complete. When it is done, it will give you in the konsole a URL that I ask you post here, so we can examine the audio configuration. With that information we may be able to provide some recommendations.

Thankyou for posting on our forum, and good luck.

I have uploaded the info to here:

Thanks. I looked at the mixer settings and it confirms your assessment that you have tuned this best possible. Possibly if it were me I would try changing the mixer control ‘Channel Mode’ from 2ch to 4ch and back (to see if that makes a difference) but I assume it doesn’t.

Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '4ch' '6ch'
  Item0: '2ch' 

I also assume per your 1st post that you confirmed the wiring to the speakers is correct. Have you confirmed this sound functionality with a different OS other than GNU/Linux ?

Similar to what you noted, I note two instances of the alsa “snd_hda_intel” running - one associated with your on-board ALC887-VD and the other associated with HDMI (possibly associated with an AMD graphic device (Radeon HD 6400 Series)).

I note:

!!Aplay/Arecord output


**** List of PLAYBACK Hardware Devices ****
**card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]**
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]**
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]**
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Did you try a simply speaker test, that bypasses pulse, to confirm basic sound functionality ?

which tells me you have hw:0,0 as analogue audio, and hw:0,1 as digital audio, and hw:1,3 as HDMI audio.

Does this give any sound:

speaker-test -Dplug:surround51 -c2 -twav

if not, how about this - does it give alternating noise in your speakers :

speaker-test -D hw:0,0 -c2

Note I assumed 2-channel. If you are using 4-channel then that should be -c4 , or if using 5.1 (6-channel (?)) then that should be -c6.

if not, how about this:

speaker-test -D hw:0,1 -c2

or better, if you have a .wav file (I am calling somefile.wav) that you know is good, try this:

aplay -D hw:0,0 somefile.wav

or this

aplay -D hw:0,1 somefile.wav

That was no such file named asound.conf. The only thing that looked similar was asound-pulse.conf.


I tried all of the things you mentioned. Still no sound. I have also plugged in a TV to the HDMI to try and get sound from that and still nothing.

The only thing I didn’t try yet is to put a different drive in and build it Windows.

Any other suggestions?


  1. test in another OS to prove hardware is ok

  2. write a bug report on openSUSE and obtain the attention of an openSUSE packager who is also an alsa developer. Guidance here: . You can use your openSUSE forum user name and password to logon to bugzilla. Attach to the bug report a copy of
    the file obtained by sending the command:

/usr/sbin/ --no-upload

No audio from ALC887 built into my MSI A75A-G55 MB since I updated CMOS. The CMOS update fixed my intermittend USB problem but killed audio. I have had “yast2 sound” play the sample sound twice (out of hundreds of attempts).

Sound works great from Windows on this hardware.

Ouptut from “ --no-upload” is:

/usr/sbin/alsactl: save_state:1590: No soundcards found...
cat: /tmp/alsa-info.n5TRW1uZMY/alsactl.tmp: No such file or directory

I tried following the instructions at , but the format it says to use does not work in the modprobe files. Yast2 does not list any of the ALC880 models listed in HD-Audio-Models.txt. It automatically offers a BeaverCreek HDMI and FCH Azelia controller. I don’t want HDMI and neither of these produce sound.

Any suggestions?

That message is consistent with putting wrong model settings in YaST > Hardware > sound.

I need something ‘clean’ from to work with to undersanding your problem. The description provided does not give information that means anything to me. Please remove any /etc/modprobe.d/50-sound.conf file, then reboot, and then configure with YaST. Do NOT apply any models in YaST. Reboot and test again. Then if no sound, as a regular user in an xterm/konsole, with PC connected to the internet, send the command:


and do not update if asked, and select the SHARE/UPLOAD selection, and let the script run to completion. After it completes it will put an address/url that you are recommended to share in the konsole/xterm. Copy and paste that URL/webaddress here so we can go to the site it provides and look at the audio configuration.


I have sound now. I rebooted on my OpenSUSE Live CD to see if it could get sound working automatically. It did so I kept troubleshooting and rebooting to see where it went bad. “yast2 sound” kills sound. After running “yast2 sound” and saving anything at all–no more sound. I can then run “yast2 sound” and delete all devices and it makes no difference. I found that when Yast is exiting and clobbering my audio, it updates two files.

Fix was to completely avoid the hellish Yast module and restore the out-of-the-box contents of /etc/pulse/client.conf and /etc/sysconfig/sound that I got off of my working Live CD system. When I have time I’ll test and find out which of these two files did the trick, but for now I have to get back to my day job.

I hope this is of use to somebody else with the same symptoms.