Please Help - Modem problem w/11.0

Hello HW Forum,
I’m very new to this forum, but not to openSuse. My first openSuse 11.0 install went well except for the modem (necessary here in dial-up country).
openSuse shows the modem HW info as a LTWinModem at /dev/tty/LT0.
This problem surely isn’t new. Please point, advise, inform me, as to the next step to get this working. Using KDE3.5.

I think you need to use kinternet.

Check to see you have it installed. Then configure with your dial up details.

Thanks caf4926!
I installed kinternet, but it complains of something more basic. Its message is “connection to local and remote server refused”. There are further complaints about smpppd and my membership of the dialout group.
I will look into my group memberships.
wvdial complains "can’t open /dev/modem.
The Yast HW info has the modem at /dev/tty/LT0.
Somehow it seems that udev will need to provide a link between /dev/modem and /dev/tty/LT0.
All of this info has to be “fat fingered” into another machine that has a working modem.
Is it possible to make this Lucent Technologies WinModem work with openSuse 11.0?

Frank, I had the same exact problem when I went from SuSE 9.3 to 11.0. The linux core is either corrupt or it no longer supports Lucent Tech Winmodems. Nor will it accept the older 9.3 drivers. I posted about it and had absolutely no usable answers over at (someone suggested that I “buy” a software solution. >:( I had to use my 9.3 version to even ask the question. Good thing I partitioned properly and saved that version as a dual-boot option.

I ended up having to purchase a controller based modem. The one I bought was a USR USB modem. Costs about $50 including shipping from TigerDirect. The modem installed without a hitch and worked from day one.

That not only solved my problem, but pretty much guarantees that I will have a usable modem from this point on, at least until broadband hits my area.

I know this may not help you much, but it was the only workable short and long term solution, for me.

Thanks for the input AlNorris,
For myself with 10.2, I use a USR HW modem also. Your input is valuable to me as it allows me to stop wasting time with the LTWM.
For this particular installation I have another modem option to try.
An XP machine here has a Moto NetoDragon WinModem. It will have a driver for the LTWM, so I’ll first experiment with a modem swap.
As a follow-on to my earlier post to this thread, the user was a member of the group dialup from the start. When I checked, I also added him to the modem group.
In my personal 10.2 system I used kppp rather than kinternet. Kppp is loaded here also and fails finding nothing at /dev/modem. The port choices kppp has does not include /dev/tty/LT0!

Hi There,

If you do have to go the route of getting a new modem, you might want to just consider an external one. I found long ago these were the easiest to use with Linux, then you never really have to worry about drivers, etc. - just connect to serial port and you are set.

Good luck, and sorry to hear your misfortune.

(Humm . . . is it possible to compile a kernel module to support that Winmodem? Bah - easier in the long rung to skip it.)


Before you do anything else, go to YAST / System / System Services and turn on smpppd. You need to have this running for dial up connections to work.

Then run the Modem wizard thing in YAST / Network / Devices/ Modems. Then try connecting with Kinternet. If you right click on the little taskbar icon you can select “view log” to see what’s going on while you try to connect.

Thank you foresthill!
With your help, I got a little farther. Before I got your message, I had already swapped the LT WinModem for the Motorola SmartModem, also a WinModem. One difference is that it where the LT port was /dev/ttyLT0, the Moto port is /dev/ttySL0.
When I ran the Yast > NetworkDevices > Modem, I edited the SmartModem entry. After selecting the modem port to be /dev/ttySL0, the wizard created the link /dev/modem -> /dev/ttySL0.
From here it’s still a no-go! Knetwork gets the same errors as before, tho it seems to run from the wizard checklist. Kppp can’t open the modem and wvdial says the modem or resource is busy.
It seems that some application has the modem locked up. What is a good way to show the allocation of a device or resource?

“Modem is busy” messages are typical when trying to get an unsupported winmodem to work.

What you need is an external serial modem of some sort. These work quite well from my experience.

US Robotics used to make some good internal PCI hardware-based modems that would work in Linux, but they are not manufactured any more.

Hopefully you have a serial port, and if so, even the cheapest most generic serial modem will work like a charm.

There was a driver for earlier versions of Suse that would allow some winmodems to work, but it has not been maintained.

So as things stand, you need either a hardware based internal modem (good luck finding one these days) or pretty much ANY serial modem. Note that even if you have no serial ports, USB to serial adapters are available for a few dollars and they work quite well.

Some USB external modems are said to work, but I have not had much luck with any of the ones I tried.

Don’t know if this will help, I just spotted it
Bryan手札-生活記趣 » How to connect to internet by PPPOE (KDE or Gnome) on Opensuse

page was slow loading for me

Thanks again caf4926!
It will take some time to digest Bryan’s information in the link you sent me, but I’m anxious to try it.
I’ve been a KDE user thru several Linux distributions, but maybe Gnome will have a better modem interface this time.
Bryan does present both KDE and Gnome solutions. My hope are that I can get his KDE solution to work.

So replying to my own thread to update it.
Bryan’s modem instructions for KDE are relatively simple. Everything works for me until I have to “click” on Kinternet. Kinternet crashes. I saved the crash details, but apparently no file attachments here!
Two things I’m wondering:
1.) Is Kinternet supposed to work with KDE 3.9?
2.) Should I be setting up my dial-up modem as DSL? Bryan uses a DSL setup.]

If I understand correctly, you are using a Modem as in the old winmodem type v.92/56kbit/s ?
ie: Dial-up internet access - Wikipedia, the free encyclopedia

and not:Digital subscriber line - Wikipedia, the free encyclopedia

A cheap option would be to get one of the US Robotics internal modems. As
foresthill pointed out, they’re not made anymore. There are however many of
them on ebay that seemingly nobody bids on. (so they’re cheap!)
I put a US Robotics internal (these are hardware-based) modem in under
OpenSuse 11 running KDE3.5. It took just a few minutes, mostly entering the
ISP information, to get it running. Select Modem and not DSL under your
network devices in Yast. One thing I found that I needed to do was check
the “Stupid Mode” option in one desktop and “Ignore Prompts” in this

caf4926 wrote:

> If I understand correctly, you are using a Modem as in the old winmodem
> type v.92/56kbit/s ?
> ie: ‘Dial-up internet access - Wikipedia, the free encyclopedia’
> (
> and not:‘Digital subscriber line - Wikipedia, the free encyclopedia’
> (

Thanks again caf… and Tom…,
Posting with a second page of thread isn’t letting me see the posts I’m replying to.
Yes caf… I an in true dial-up territory with a 56Kbaud serial WinModem of the V.92 type. Also my KDE is 3.5.9, not 3.9.
Tom, your suggestion of alternate modem hardware may be the only option to use 11.0! Your “stupid mode” and “ignore prompts” may be what I need to finish with the Smart-Link WinModem I’m using now.
One more piece to the puzzle, I think I’m going to need is a UDEV rule to make a persistant link between /dev/modem and /dev/tty/SL0. I would call this rule maybe 70-persistant-modem.rules. Any volunteers out there with a sample rule for me?
Since last post I tried Bryan’s KDE method unsuccessfully, then his Gnome method. Kinternet does’t crash in Gnome, but I didn’t get a connection either.
Last I reinstalled 11.0 with KDE3.5.9 and sellected all Bryan’s rpms in the install setup. The installation started Kinternet. This time I avoided running it like Bryan did, before starting the smpppd. After Kinternet errors it doesn’t allow Yast setup. The Kinternet Yast setup creates the /dev/modem link.
Bryan’s last step (he’s doing DSL) was a reboot. Tho I’m doing a V.90 modem only, I rebooted. Even with Kinternet setup to start with KDE boot, it didn’t come back up and the /dev/modem link is empty. The only way I know of so far to start Kinternet is from the menu which will make it error. The error changes Kinternet’s future behavior.
I think I can make this work! It seems I’m very close. I’ve cobbled together Udev rules in the past, but a suggestion would be welcome.

You know it is so many years since I used kinternet I can’t recall much.

I’m fairly confident that your main concern is not if kinternet starts at boot.

But rather the support for winmodems or rather the lack of it. I did use dialup at one time and it was never an issue. And interestingly, my current Mainboards on-board modem seems to be recognized ok, though I haven’t tried it.
Check the list of modems listed in Yast when you go to configure your device. See if it lists something like:
SmartLink SmartPCI562 56K Modem

Check this site: Hardware for Linux - Search

I should think ebay would be a likely source if you have to buy one. I’m surprised some more dialup users have not replied in this thread.

Yast2 does load a SmartLink driver for my modem. It’s smartlink-softmodem-2.9.10-203.1. Having a modem driver for my modem leads me to believe that the problem is with the openSuse 11.0 dialers.
There is no man page for kinternet, tho there is a help message with --help. Kinternet errors when invoked in either KDE 3.5.9 or KDE 4.0. The root invocation is:
DCOPClient::attach Internal. Attach failed Could not open network socket
Kbuild sycoca running.
As a user, the invocation error is:
KCrash Application ‘kinternet crashing’. I think the difference is due to permissions, possibly pppd, tho pppd group is dialout. As a user I am a member of the dialout group.
Then there is the matter of the modem link. Yast2 creates the symlink /dev/modem → /dev/ttySL0. A Udev rule is going to be needed to make this link persistant or I will have to run Yast2 on every reboot!
Of course I can write a script that runs at boot-up, but that defeats the purpose of udev.
Pppd give me the impression it can talk to the modem at low level at least if invoked as root. It has a debug mode and a manpage, so maybe I can decypher what’s going wrong.
The kinternet log gives pppd0 error 2.
Return status 2 according to the pppd manpage is a contradiction of commands or commands in conflict.
I have KDE4.0 installed now so I will use that evironment to poke around with pppd.
Personally I have been favorably impressed by the attention my post has received. With the modem driver in the distro pack this should have been a non-problem. The resolution is likely to be some thing simple like a setuid somewhere.
Thanks for your support caf4926

Kinternet works fine in OpenSuse 11, I use it every day to connect to the internet with my EVDO wireless broadband modem. Kinternet does crash sometimes, but once you update your kernel these crashes seem to go away.

For help on ppp connections enter man pppd into the terminal for a wealth of info on establishing connections.

Also you could install kppp and use the “query modem” feature to see if you can get the modem to respond that way.

If all else fails, you can purchase a winmodem driver from linuxant, or maybe try their free crippled driver out just to see if you can get the modem to respond with that. I personally think their product and business model are both awful, but you might like dealing with them.

I have been through all this already. I spent weeks fighting with various winmodems, always thinking I was getting so close to a solution to the problem, but I never got one to work (except by buying the linuxant driver which I hated).

So unless you are having a great deal of fun trying to solve this problem, it’s a battle best avoided by simply buying an inexpensive serial modem.

Thanks for the input ForestHill!
It’s a “catch 22” to update the kernel without an internet link. I’m shuttling information between computers on a floppy now.
Tho it’s heresy on this forum, another option may be to defect to a distro more receptive to WinModems.
For the record, I dug into the low-level details of the driver. The softmodem rpm that gets loaded uses Alsa libs. The smartlink-softmodem daemon /etc/sysconfig/slmodemd is set up by yast system configuration as an Alsa based modem. Slmodemd does’t load a kernal modem if the modem is Alsa based.

The Alsa README lists my PCI561 and gives a list of Alsa drivers for the Alsa modems.
None of the Alsa drivers are loaded, nor the smartlink drivers for non-Alsa modems.

I edited an echo statement into the slmodemd invocation to see the variable expansion, then manually exectuted it as root in the form “nohup statement &” and viewed the nohup.out file.

Here’s the expanded statement:
startproc -l /var/log/slmodemd -s /usr/sbin/slmodemd --country=USA -a modem:1

Now the nohup.out contents:
error: mixer setup: attach hw:1 error: No such file or directory
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 1
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM modem:1
error: alsa setup: cannot open playback device ‘modem:1’: Invalid argument
error: cannot setup device `modem:1

The /var/log/slmodemd entry is just a one-liner that gives the daemon name and the time.
So if you’re still with me here, yast thinks correctly that my PCI561 is an Alsa based modem, but in my opinion no Alsa driver is getting loaded.
There’s a lot of pieces to this puzzle. I’m going to see if my Alsa list can shed any more light on this!

I’m back replying to my own thread!
Nothing yet from my alsa-user list!

Like ForestHill wrote, it’s an endless maze to untangle. I’m curious if ForestHill attempted to configure smartlink winmodems in his earlier efforts.

Further unsuccessful attempts on my part include: Kppp can’t open the modem! Slmodemd won’t start. Startproc in an attempt to run slmodemd returns status=7 meaning slmodemd not running!

Linuxant is on my mind now. Will they have a smartlink diver for sale? I’m also looking into a HW modem. I haven’t found any other distros that are touting easier modem setup!

Has anyone on this forum built the smartlink modem driver slamr? There’s a build package for it as recent as 2005.

In my experience the old makefile syntax gets out of date. It’s more work to fix the makefile syntax than to build the driver!

So if anyone is still with me here, I think there is a chance that slamr built with 11.0 can work as the kernelspace driver I’m missing.

From what I’ve read, slmodemd is a userspace driver that needs a kernelspace companion. 11.0 may expect the kernelspace driver to come from alsa such as snd-intel-8x0m.

As a last gasp, I’m going to try to build slamr. It comes with its own slmodemd. If I get the build to work, I’ll try to merge the slamr kernelspace driver with one of the two slmodemd versions I will then have.

Again, please chime anyone in if you tried this yourself, for better or worse!
Frank K