Please help me to get sound in my laptop

Hi OpenSuSE community.
I just installed OpenSuSE 12.1 in my ASUS U52F BBL9, the codecs are

head -n 1 /proc/asound/card0/codec*

==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC269VB

==> /proc/asound/card0/codec#3 <==
Codec: Intel IbexPeak HDMI

Can somebody please help me to create my /etc/modprobe.d/50-sound.conf I currently have no sound and I would appreciate all help with this.
Thank you!w

Did I say I would appreciate it?

This file is nominally created by YaST > Hardware > Sound when you edit your sound card configuration.

What test have you done to confirm sound is not functioning ?

Have you installed the application pulse audio volume control (pavucontrol) and used that to tune pulse for your applications audio applications at the same time in which you are playing media back in those applications?

Based on what you posted, I am not convinced the sound problem you have needs a fix to the 50-sound.conf. But to answer your question, the model options for the ALC269 are:

  basic		Basic preset
  quanta	Quanta FL1
  laptop-amic	Laptops with analog-mic input
  laptop-dmic	Laptops with digital-mic input
  fujitsu	FSC Amilo
  lifebook	Fujitsu Lifebook S6420
  auto		auto-config reading BIOS (default)

and to apply an option (say ‘fujitsu’ ) one would add this line to the start of that file, restart the sound driver and test:

options snd-hda-intel model=fujitsu

but again, based on your rather sparse post, I am not convinced that is the nature of the problem.

Thank you for the info, It worked!
I just changed the model part in that file using a text editor I just selected the auto model, then I also had to add my user account to the audio group with the YasT tool, rebooted and got sound.

How can I mark this thread as SOLVED?
I appreciate it.

Congratulations. Glad to read that on an ASUS U52F BBL9 (with openSUSE-12.1) one selects the model option ‘auto’ and also adds their user to group ‘audio’ to obtain functional sound.

We nominally do not apply a ‘solved’ label to threads. If you wish to post anything, a simple ‘SOLVED’ is sufficient.