please help me disable bug buddy

so i have a problem with firefox 3.0.3 in GNOME on openSUSE 11 32bit

whenever i watch flash videos firefox crashes and completely closes itself

i can usually watch like 3 or 4 before this happens

i realize this is a known issue with flash and firefox but i think bug buddy is adding to my problem

currently i am dual booting with Ubuntu 8.04

in Ubuntu i have the same exact version of flash and the same exact version of firefox

in ubuntu i also have the same problems where flash messes up

the difference is that in Ubuntu when flash crashes firefox stays open! meaning i can simply refresh the page to make it start working again

also in ubuntu i dont think i have bug buddy
(if i do, then it has never been enabled)

now i have noticed that in SUSE when flash crashes bug buddy will pop up and firefox is still open

its only after i close bug buddy that firefox closes

this leads me to believe that bug buddy is actually adding to my problem with flash

so i tried removing bug buddy through yast, but it tells me that gnome-session2.22.1.1-44.1.i586 requires bug buddy

so is there any way i can remove (or at least disable) bug buddy without messing up my gnome desktop?

Hi
You need to set GNOME_DISABLE_CRASH_DIALOG=1 in your
environment to disable bug-buddy altogether. You could add the
following to your .profile;


# Disable Bug-Buddy
export GNOME_DISABLE_CRASH_DIALOG=1

Next time you login it will automatically activate it.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 12:24, 2 users, load average: 0.39, 0.36, 0.20
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Hi
You need to set GNOME_DISABLE_CRASH_DIALOG=1 in your
environment to disable bug-buddy altogether. You could add the
following to your .profile;
Code:

Disable Bug-Buddy

export GNOME_DISABLE_CRASH_DIALOG=1

Next time you login it will automatically activate it.

thanks it worked

it didnt actually solve my probelm with firefox, like i was hoping

but… at least now i dont have to deal with the popup