Please help me connect to the Internet

I’ve recently open SUSE 12.3 (32bit) into my PC .The frustrating thing is when I use a live CD (open SUSE 11.2) which is what
I’m using now, as I write, I have no problems connecting to the Internet. However, I cannot get the very same TP-LINK wireless
adapter to connect to the Internet in SUSE 12.3.

I suspect there is something missing somewhere, I’m just not sure what it is being a complete newbie to SUSE Linux

Anyway here is some stuff from the terminal thnat I hope will help you help me.

us 001 Device 003: ID 0cf3:7015 Atheros Communications, Inc.
TP-Link TL-WN821N v3 802.11n [Atheros AR7010+AR9287]

usb 1-3: New USB device found, idVendor=0cf3, idProduct=7015
1.308925] usb 1-3: New USB device strings: Mfr=16, Product=32, SerialNumber=48
1.308928] usb 1-3: Product: USB WLAN
1.308930] usb 1-3: Manufacturer: ATHEROS
1.308933] usb 1-3: SerialNumber: 12345

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 Interface doesn’t support scanning : Network is down

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning

Thanks for your kind help

Hello and welcome here.M

Maybe you have seen that the information you provided by copying computer text here is malformed. Please next time copy/paste this between CODE tags. You get the CODE tags by clicking on the # button in the tool bar of the post editor. And please, when you use a command to create the output, include the prompt and the comand together with the output. So we can see what you did.

Hi, welcome !!!

First, please post output between CODE tags, the # in the editor. Makes it much more readable for us.

A couple of questions:

  • Did you also try a 12.3 Live medium (they don’t fit on CD anymore, but it’s easy to create a bootable USB device)?
  • How did you set the networking? ifup or Networkmanager?
  • Is the USB wifi stick available at boottime?
  • Output from

ip addr

An issue like this is going to be one of three things. 1) wrong or bad driver. 2) wrong password. 3) wireless interference.

I feel it’s rather unlikely that it’s the last two.

Paste the output of lsusb and modprobe.

Once we have this, we can then decide if you want to use traditional method (ifconfig) or NetworkManager.

By the way, here is the page for the driver details; http://wireless.kernel.org/en/users/Drivers/ath9k_htc

Thanks for your help. The problem seemed to be a bug in the network
manager. The following code fixed it.

systemctl is-active network.service &&
systemctl stop network.service

systemctl --force enable NetworkManager.service

systemctl start network.service

I rebooted and started the process of connecting to the Internet and everything
worked fine after that.

It is nice you found a solution. And it is appreciated that you report back for the benifit of others. But there is no need to shout to us by using a different font from the default. Also it would be very much appreciated when you post those computer commands between CODE tags, as asked above.

On 2013-06-10 12:06, tee4me wrote:
>
> Thanks for your help. The problem seemed to be a bug in the
> network
> manager. The following code fixed it.

Did you read the release notes?

Ditto re using code tags, and fonts.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)