PLEASE HELP! Graphics Driver Not Loading

Morning people,

My graphics driver does not load anymore, although I do get X it is running
extremely slow and while the driver install did something it actually failed.
I am running 11.2 64-bits and installed Catalyst 10.9 driver.

The symptoms:

>fglrxinfo
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 136 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 15
Current serial number in output stream: 15

>lsmod | grep -i fgl
[NO OUTPUT]

>lsmod | grep -i rad
[NO OUTPUT] (The last time I had a fgl loading problem, there were 2 drivers loaded)

>cat /usr/share/ati
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o .ko .GCC .?? *.symvers
make -C /lib/modules/2.6.31.14-0.1-default/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory /usr/src/linux-2.6.31.14-0.1-obj/x86_64/default' make -C ../../../linux-2.6.31.14-0.1 O=/usr/src/linux-2.6.31.14-0.1-obj/x86_64/default/. modules CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c: In function ‘KCL_IOCTL_AllocUserSpace32’: /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c:196: error: implicit declaration of function ‘compat_alloc_user_space’ /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c:196: warning: return makes pointer from integer without a cast make[4]: *** [/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o] Error 1 make[3]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2 make[2]: *** [sub-make] Error 2 make[1]: *** [all] Error 2 make[1]: Leaving directory /usr/src/linux-2.6.31.14-0.1-obj/x86_64/default’
make: *** [kmod_build] Error 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
[Message] Kernel Module : update initramfs not required

Obviously something failed during the driver install. Here is the background story
if that can help:

  • Yesterday everything was working absolutely fine.
  • There was a kernel security update that appeared last night and required
    a reboot.
  • When I rebooted the machine, I had no cursor.
  • This usually happened to me with each kernel updates and the solution was
    simply to reinstall the ATI driver.
  • Reinstalled the ATI driver and …instead of solving the problem… I lost all
    graphics X would not load at all.
  • I to uninstall/reinstall the ATI driver several times and still the same problem,
    no graphics at all.
  • Finally I used another computer to download a new ATI driver, installed it and
    X was starting again but the driver is not loaded… so something in the driver
    installed fixed X but the install didn’t complete. The ATI driver did no even say
    that, only that the install worked and a reboot was recommended. Needless to
    say I rebooted several times since then but the system in nearly unusable.

Any help would be greatly appreciated.

Thanks in advance,

  • Itai

Just check there isn’t any info here
ATI Drivers - New Release, 10.9

Hello Itai,
i hit the same issue yesterday which is really annoying >:(

I installed the new kernel desktop kernel-desktop-2.6.31.14-0.1.1.x86_64.rpm yesterday and after the reboot the X11 server crashed. So i installed the newest ATI Driver (10.9) via safe mode and it works fine. The installer says that everything went fine and i am able to login in graphic mode again.

But the whole X11 stuff is very very slow (scrolling and browsing with firefox is nearly impossible).

The fglrx-install.log contains


[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
make -C /lib/modules/2.6.31.14-0.1-desktop/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.31.14-0.1-obj/x86_64/desktop'
make -C ../../../linux-2.6.31.14-0.1 O=/usr/src/linux-2.6.31.14-0.1-obj/x86_64/desktop/. modules
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c: In function ‘KCL_IOCTL_AllocUserSpace32’:
/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c:196: error: implicit declaration of function ‘compat_alloc_user_space’
/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c:196: warning: return makes pointer from integer without a cast
make[4]: *** [/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o] Error 1
make[3]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.31.14-0.1-obj/x86_64/desktop'
make: *** [kmod_build] Error 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
[Message] Kernel Module : update initramfs not required


shell>fglrxinfo
 Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  15
  Current serial number in output stream:  15

Also the kernel module is not build :frowning: … didn’t find any solution until yet.

Hardware: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]

UPDATE : This seems to be a known problem with the new patched kernels (posts are in german): http://forum.ubuntuusers.de/topic/fglrx-compiz-seit-heute-nicht-mehr-installierb/#post-2626290

Regards

OK… we’re in the same boat. If the problem is ‘known’ I guess this means there
is no solution?

How do we revert the kernel then? I really need the system to work, a broken
patched system is of no use to me obviously. I hate that I can’t simply tell what
was updated and revert it in situations like this. If you know of a way, please
let me know.

>I installed the new kernel desktop kernel-desktop-2.6.31.14-0.1.1.x86_64.rpm >yesterday and after the reboot the X11 server crashed. So i installed the newest >ATI Driver (10.9) via safe mode and it works fine. The installer says that everything >went fine and i am able to login in graphic mode again.
>
>But the whole X11 stuff is very very slow (scrolling and browsing with firefox is >nearly impossible).

Indeed, this is exactly what I did and the symptoms that I had. The installing
actually failed, despite saying the contrary, it just happens to have fixed X along
the way of failing… At least that was one good thing :wink: That is why everything
is so slow. The ATI driver is NOT loaded and we are using whatever generic fallback
there is (I assume VESA).

I see only two possibilities here, we revert the update and wait until there is either
a fix to the ATI driver or a new update which does not brake the driver.

OR… we try again the non-proprietary drivers. At least those are supposed to keep
in sync with kernel updates. Eventually I would like things to simply work like that
because I’ve had to reinstall the ATI drivers on EVERY kernel update. >:)

Guess you could roll back to the original kernel from release 11.2 in OSS if that worked!?!
In future you could do this
Keyboard & mouse freezes

I would gladly do it IF I knew how :frowning:

Yast does not seem to give me that option? Do I need to edit a config or
the repositories or something? Please let me know.

Thanks in advance,

  • Itai

Hi,

I fixed this issue by modifying the code of ATI


shell> vi /lib/modules/fglrx/build_mod/kcl_ioctl.c
*/ ... go to line 197 and replace that line with ...*/
return arch_compat_alloc_user_space(size);

After that recompile the kernel module and reboot your system. The driver is loaded fine and the performance is also ok.

Regards

Amazing how much difference 5 characters can make! :slight_smile:

THANK YOU SO MUCH!

This worked… it’s all back to normal now.

All the best,

Hey, Thank you very much!
Exactly the same problem here (OpenSuse 11.2, ati-driver-installer-10-9-x86.x86_64.run). The quickfix works smooth. For some reason, it was line 196 at my system, but well, close enough :slight_smile:

Greetings, Kjell

Thanks for this. Helped me too.

Yes, the fix works. Line is not 197 but 196. However, Catalyst Control Center shows version 10.8 (installed previously, before the kernel update to 2.6.31.14) although Catalyst 10.9 was installed after the kernel update.

This fixed worked great for me on multiple machines with the latest 11.3 kernel patch/ Catalyst 10.9 x64 non-compilation issue.

Hi, I know how to modify the appropriate line of code in /lib/modules/fglrx/build_mod/kcl_ioctl.c, but what do I do to recompile the kernel module (and which kernel module)?

On 2010-09-28 12:36, jussi-cat2 wrote:

> Hi, I know how to modify the appropriate line of code in
> /lib/modules/fglrx/build_mod/kcl_ioctl.c, but what do I do to recompile
> the kernel module (and which kernel module)?

See if this helps:

<http://lists.opensuse.org/opensuse/2010-09/msg01642.html>


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Hi guys, I got the same trouble. So, I edited that file, but I don’t know how to “recompile the kernel module”. Should I run the following command or what?:
make -C /lib/modules/2.6.34.7-0.3-desktop/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules

Thanks in advance

So, the problem seems to be resolved. What I did:

  1. Downloaded a sh-script from here: openSUSE 11.3 – proprietären Grafik-Treiber ATI Catalyst 10.9 als RPM installieren

This page is in German language, that’s why translate.google.com will be quite useful :wink:

  1. Changed the runlevel to 3 (“init 3” command).

  2. Ran the downloaded script with the parameter “-i”.

It downloaded the needed ATI driver, checked it for compatibility with my video card, patched it and compiled the kernel module.

  1. Rebooted my laptop

Now the problem seems to be resolved. Many thanks to the author of that script!

Greetz.

This may be more suited to those that doesnt have the time to tinker with their systems / not too comfortable with editing files. It essentially automates stuff for you so one doesnt have to re-invent the wheel, so to speak.

ATI Catalyst 10.9 has issues with compiling for the latest kernel 2.6.34 which most systems will update to due to security patches/fixes. Most users however, would find that after they apply the needed security updates, X will have problems.

Getting Catalyst 10.9 to Run on openSuSE11.3 x86_64 (kernel 2.6.34.7-0.3-desktop)
Preconditions:

  1. Fresh standard install of openSuSE 11.3 x86_64, with KDE Graphical Desktop Environment.
  2. You have already verified that your graphics card is supported by ATI’s Catalyst drivers.

Prep Stage
*1. Determine your installed kernel flavor. **
Issue this command from the terminal: ‘uname -r’
Output is something like: 2.6.x.y-pae or 2.6.x.y-smp or 2.6.x.y-desktop depending on your system. Let’s call this your kernel flavor. You will need this info when you get to Step 3 below.
Note the default video drivers loaded/used by KDE.
Click on “My Computer” on the default plasma folder. Note the details provided in the ‘Display Info’ section, particularly the 2D and 3D drivers currently used by X.
2. Get needed packages.
Make sure the following packages are available: {gcc, make, patch, kernel-devel, kernel-flavor-devel,kernel-source, kernel-syms, module-init-tools, glibc, glib-devel, zlib
, libstdc++, libgcc}
3. Update your openSuSE sytem to install all NEEDED patches.
You will be asked to reboot, and your kernel will become 2.6.34.7-0.3-flavor or something similar.
4.Get the latest Catalyst Display Driver (Rev 10.9) from ATI’s website.
5. Remove any pre-existing fglrx modules running on your system.
Ignore this step if no fglrx modules are running and loaded in your system.
(Command to list existing fglrx modules) rpm -qa | grep -E ‘fglrxG01|fglrxG02’
(Command to remove existing fglrx modules) zypper rm 'rpm -qa | grep -E ‘fglrxG01|fglrxG02’ ’
(You can also use YaST to remove the existing fglrx modules if you want, instead of zypper)

Install Stage
6. Go to runlevel 3, log-in and become the superuser. (init 3 / telinit 3)
7. Get Sebastian Siebert’s script.
This script will simplify and automate patching of compat_alloc_user_space() which if not done will break the compile process for ATI’s Catayst Display Driver with kernel 2.6.34.7-0.3.
This script will also check for needed packages and get them for you automatically. It then runs ATI’s installer to automagically set things up for you! (Thanks and credit to Mr. Sebastian Siebert).

wget http://www.sebastian-siebert.de/downloads/makerpm-ati-10.9.sh
8. Get download checksum and verify integrity of downloaded file.
wget http://www.sebastian-siebert.de/downloads/make-rpm-ati-10.9.sh.sha1
sha1sum -c makerpm-ati-10.9.sh.sha1
Screen output should be like: makerpm-ati-10.9.sh: OK
9. Change file ownership and permission of downloaded script file.
chown root:root makerpm-ati-10.9.sh
chmod 744 makrpm-ati-10.9.sh
10. Finally, run the script.
./makerpm-ati-10.9.sh -i
That’s it. Reboot your machine and check the display drivers loaded by KDE in ‘My Computer’.

Sebastian Siebert offers an optional but highly recommended step to ensure that the system will build the fglrx kernel module before starting the desktop GUI environment in case another kernel update becomes necessary. (./makerpm-ati-10.9.sh -irs)

[Thanks to Google Translate which allowed me to understand Mr. Siebert’s instructions in his website]

I have an AMD64 box with the latest 2.6.34.7-0.3-desktop kernel. I had previously installed the 10.9 driver from the ATI website *, which ran fine until the kernel “upgrade”. Then it failed in the way described above. After editing the kcl_ioctl.c file, I noted a make.sh script in the same directory, and a make_install.sh script in the parent. I ran them as root; ran aticonfig --initial; and rebooted. Things worked fine afterwards.

HTH*

I did the same thing as you (minus the aticonfig command, it wasn’t even necessary for me)

You don’t have to bother with the german scripts or anything above… Just modify the source file as outlined, in the same folder execute make.sh, then it will tell you the name of a make_install.sh file to run. Do that, reboot, back & good as new! Thanks guys*