Please Help! - Blank screen of death!

Hiya, I have wanted to convert to linux for the past 4 or so years and have tried on 3 occasions (each time with Suse- I just love the idea of YaST) but every time I do I run into problems, mainly because its so different.

I have read a few guides to Linux and understand how to install and all the basics (though wish it had an instal shield like windows :)) but I am having major problems with drivers :’(

I installed Suse on my computer fine (partitioning and multi boot all ok - I am good with computers/windows) but suse had found a default driver for my card (ATI Radeon X3200) and when I applied some effects like transparancy the screen went blank leaving me with just a mouse cursor… I waited expecting it to revert back to default after a given time but nothing, and even after re installing suse (3 times) I still get the same problem when I re-boot (the first start up is fine)

Lastly on the last few installations suse has not recognised my ethernet card and wont let me conect to the internet, the first time via Live CD install was fine, but after the DVD install it stopped recognising it, even when i re installed with Live CD (each time I re install i tel it to delete the linux partitions and re-start a fresh but I think its keeping some settings?)

So I have trailed through the internet and not been able to find any help and I desperately want to make the leap of faith this time so please can somebody help be both fix my blank screen and tell me how to install the correct driver (I have found and downloaded from

Please can you guys give me some help or guidance, because I love the concept of Linux, and I love learning new things but just need a help to start! p.s. want beryl/compiz fusion so badly!!! pretty :stuck_out_tongue:

Thankyou & sorry for long essay!!!

I had also problem with monitor - during instalation in test of hardware monitor was swithed off.
I solve it by this way - I turned power off. After new boot I ended instalation and within yast2 I instaled nvidia repo (video server). And problem disapears. It could be done also in setting of software in instalation.

Have you tried the drivers from the ATI repository? Try booting with failsafe, follow the instructions here ATI - openSUSE, and reconfigure the video with sax2.