Please help... ATI Driver problems!

Well… I have reinstalled openSUSE 11.0 for the second time because of ATI problems. I have radeon xpress 200. Both times I’ve tried and restarted GNOME, when I log back on it shows a blank white screen. This time around, I added the ATI respiratory. I think that has done something. But whenever I turn on desktop effects, I get that same blank screen. Luckily I was able to turn them off with random clicking. I wasnt able to even turn them on before adding the respiratory. Even if this does mean that the driver is installed, games like Extreme Tux Racer run very slowly, which gives me the impression that it still isn’t installed or the wrong driver is. Any help? Im dying here.

This is my way of doing it

  1. go to ATI site Advanced Micro Devices Inc. and download latest driver

  2. as root, IN TERMINAL , change it to be executable… #> chmod a+x

  3. run it to install, and use recommended installation. Start it with #> ./

  4. reboot

  5. when GRUB menu appear, just type “init 3” without quotes and press enter. That will boot into console. This is unnecessary step, but I like it that way. That will save me from killing X server with brute force.

  6. log as root and type: #> sax2 -r -m 0=fglrx

that will open SAX and after you confirm resolution, new will be saved.
7. you may type “init 5”, but I like typing “reboot”

beli0135 wrote:

> This is my way of doing it

Here is a quicker way ( the linux way ) :wink:
> 1. go to ATI site ‘Advanced Micro Devices Inc.’ (
> and download latest driver
> 2. as root, IN TERMINAL , change it to be executable… #> chmod a+x

No need to change the perms it already is executable.

If you gat an error and it will not compile make sure you have all the
needed stuff ( kernel source, gcc, make etc… details on the ATI site )

> 3. run it to install, and use recommended installation. Start it with
> #> ./
> 4. reboot

This is linux not other OS, no need to reboot, press Ctrl+Alt+F1 login
as root and type:

init 3
aticonfig --initial
init 5


When back in X use the Ati control centre to configure your graphics, if
you cannot find it in the menu then open a konsole and type:


( there is a prob with it not being included in the menus )

Here are the official installation docs from AMD/ATI:


PS. @beli0135, your way does work and I am not being awkward just
pointing out that linux does things a little bit different, reboots are
seldom needed except for kernel updates and major arch alterations.

i have radeon 3850 and i install like you post but when i try to start x server it freeze and i have some purple lines. help please!!!

I too have an ATI Xpress 200m on my laptop. Make sure to enable “shared” memory in the Bios. I believe this is still required for the proprietary Radeon driver.
Mine works great, but I don’t play too many games. The 3-D desktop effect provided by Compiz runs fine for me, which was my goal.
Note, as of SuSE 11.1, the standard “radeon” driver now has 3-D enabled due to the recent resolution of a bug. For me, booting to any of the 11.1 variations AND Ubuntu’s 8.10 release have 3-D goodness out of the box.



I have the HD3850 running OpenGL 2.1.8304 with 11.1 on an i7.

The only proplem with my installation the system hangs when a user exits an Xsession. This is to be fixed later.

There is a problem with the way the ATI software compiles the fglrx kernel module for SuSE/SUSE111-AMD64.

Here is what I did or had to do.

  1. at GRUB screen:
    backspace out the vga=0x31a (this prevents the vesa fb from starting)
    replace the deleted vga text with the numeral 3 (boot to init 3)

2.# yast2
Install the Kernel source. The required GCC packages should be installed as dependencies automatically.
Install libstdc++33-3.3.3-7.10 (ati wants this version of c++)
Install libstdc++33-32bit-3.3.3-7.10 (may not be required)
Install Mesa and Mesa-32bit (most likley already installed)
Install xorg-x11 (most likley already installed)

  1. prepare kernel source for ATI software installation:

    cd /usr/src/linux

    make clean

    make mrproper

    make cloneconfig

    make prepare

    make modules_prepare

  2. download the

  3. make the installer executable.

    chmod 755

  4. Build an rpm package for SuSE 11.1 X64.

    ./ --buildpkg SuSE/SUSE111-AMD64

  5. There should be a new rpm file called fglrx64_7_4_0_SUSE111-8.561-1.x86_64.rpm. Install it.

rpm -ivh fglrx64_7_4_0_SUSE111-8.561-1.x86_64.rpm

This rpm builds a kernel module, installs the ATI software, libGL, and other X modules.
If there are any failed dependecies go back to yast2 and install them.

  1. ATI / Mesa work arounds:

If the rpm from step 7 installed ok your still not done.

The Mesa package has its own’s in /usr/lib and /usr/lib64 that might be loaded instead of ATI’s in /usr/X11R6/lib and /usr/X11R6/lib64.

cd /usr/lib

mkdir hide

mv -i* ./hide

cd /usr/lib64

mkdir hide

mv -i* ./hide

  1. OK one more thing very important. The fglrx module is trying open a libray file that is in the wrong executable format for the X server and stops the 3d goodies durring an X session.

cd /usr/lib/dri

mkdir hide

mv -i ./hide

ln -s /usr/lib64/dri/

  1. configuration. Have ATI format your existing /etx/X11/xorg.conf file.

aticonfig --initial -f

If there is an error like there is no xorg.conf or no screen found copy the xorg.conf.install to xorg.conf and run the aticonfig again.

Forget the Sax2 -r -m 0=fglrx for now.

  1. Append the following to the new xorg.conf file:

Section “DRI”
Group “video”
Mode 0660

  1. reboot back to init 3 like in step 1.

  2. Try it


  1. run ATI’s software in xterm


It will modfy the xorg.conf file. Add the dri section from 12.

  1. if the amdccle programme doesn’t give you the ability to set options than you will have to use the aticonfig --help to force the settings you want.

  2. Get rid of that Vesa fb at boot time.
    remove the “vga=xxx” from /boot/grub/menu.lst file.

i try but steel have same problem.

i will wait until ati 8.13 (its my lucky number) Sorry for bad gramar…

I am using suse linux since version 8.0. I now have a different ati graphic card ( radeon 1600 ). But I was never able just to run the ati linux driver without any trouble. Everytime the screen was black and white or had wrong colours with stripes. If this is an open operation system without black boxes like Windows, where the driver installation runs really easy, I really cann’t understand who is not in the position to create a working card driver. I will never buy anythink from ati for linux.

Did you try what is listed here at this thread?

click here

Martinob… you are a genious :slight_smile:


But now it’s 9.1 instead of 8.13…rotfl!

Oh, I haven’t seen this post… Better late then never…

Well, I know linux is not another OS, but:

  1. without rebooting, never worked for me. Seems that my machine couldn’t use the driver immediately after kernel module was compiled, so I needed to reboot. Why? Maybe it was just my junk box

  2. aticonfig --initial just made problems for me, in 100% of cases, so I avoid it. Or will use “sax2 -r -m 0=fglrx” or I will edit xorg.conf myself.

Passes I wrote above may not be the the nicest way, but I assure you that they are 100% successful.

This is a little off topic, but I have to say something because of the amount of time I wasted on configuring my HD3850.
Last year I built a new computer and chose to go with ATI instead of Nvidia due to articles that referred to drivers being released to the public and benchmarks.
I am officially dumping ATI. It took me about a month to get things working right back in 08. This included hacking their files to get my device to work and every time I updated their drivers my screen 1 would flip so I would move my 1999 70lb monitors around and I accepted this I guess because I have been in the USA for the last 10 years and the culture here is to train people to accept stupid ideas and junk products.
Well on a positive note, I Just got a Nvidia GTX275 for Christmas(early). All I had to do was Add their repository to YaST and install their software.
Everything works as described including their nvidia-settings program. Thought it would take all weekend but I have been pleasantly surprised at how easy the configuration is. They put a good effort into their software.