Please help a noob get the sound and touchpad working, thanks!

Hi everyone,

I am trying to set up my trusty old Toughbook CF-31 to run SUSE and am having some trouble setting up. Unfortunately this laptop is a bit strange in that not a single Linux distro will work on it out of the box with the sound or touchpad working (everything else works 100% flawlessly from what I can tell).

There is a guide that I always used to get set up on Linux Mint and other Ubuntu/Debian based distros here:

…which always worked perfectly for those distros to get my laptop’s sound and touchpad working (Mint worked perfectly), but I have no clue where to put these commands (tried installing gedit and doing this through the terminal – but doesn’t seem to work) and I’m pretty clueless what to do or what these commands would translate to on Suse (but would really like to get up and running, if possible – as I tried this distro on my other laptop, on which it works flawlessly and is now my main OS).

Any help would be massively appreciated, thanks!

The easiest way to edit bootloader settings is using YaST Boot Loader: if you are using Gnome hit the “Super” (AKA “Windows”) key and type boot, the YaST Boot Loader icon should show up.
Go to the Kernel Parameters tab, in the “Optional Kernel Command Line Parameter” field add the “i8042.nomux i8042.noloop” parameters, then hit “OK”.

To edit files as superuser use a command line editor, like nano (unless you are familiar with vi or other tools).

sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

should work as expected.
I cannot comment on whether that specific Toughbook config should work or not, but I guess likely that it does.

Thanks very much for your help! It took a few reboots, but touchpad is now finally working!

I’ve tried the command you posted and can see the config text of pulseaudio, but can’t seem to save the edit (tried it in konsole and superuser mode terminal) and am not sure where the config file is saved. Looked for nano in the Yast Software and it looks like it’s already installed (I’m probably missing something obvious, sorry). Thanks for pointing me in the right direction!

This guide may be of help to you…

Thanks a lot! I was so tired and looking for a complex answer that I don’t know how I missed the obvious, as I just hit Ctrl + S to try to save the changes to the Pulse Audio config and it worked like a charm on reboot (I think it was in the Super User Terminal) – now I have sound also! Thanks!