Please help, 12.1 to 12.2 now Gnome goes into fallback only

Things were fine with 12.1, x86_64, on my Core i7 and GTX285, and gnome-shell was running with no problems.

After upgrading to 12.2, after restarting, Gnome said it had to go to fallback. I added NVIDIA’s repository and installed their driver, as I previously had a similar issue with 12.1, and using the NVIDIA driver had fixed it. Well, the NVIDIA driver works fine and I can run nvidia-settings and OpenGL apps etc., but Gnome remains in fallback. After the initial time, the message saying it was going to fallback never showed again.

I tried deleting all related settings in my user directory, including .gnome2* etc. The .dmrc was set to twm so I changed it to gnome. Neither did anything and I still end up in fallback mode. It’s extremely frustrating because I don’t even know how to trace the problem to a cause. I looked at the .xsession-errors and I can’t figure out what’s wrong, so I’m posting it here in hope someone can: http://pastebin.com/raw.php?i=ZpCAfLAu

I bet upgrading is the cause of the problem. The Gnome version has changed and couple things have changed. ~/.gnome2 is not that relevant. What you should delete (or move) is ~/.config/dconf/user.

I deleted dconf and it still fails, except that now it shows me the message box that says it failed:

GNOME 3 Failed to Load

Unfortunately GNOME 3 failed to start properly and started in the fallback mode.

This most likely means your system (graphics hardware or driver) is not capable of delivering the full GNOME 3 experience.

Then it goes back to fallback mode >:(

Considering the NVIDIA driver is the only one that’s made Gnome 3 work properly on my system before, I’m flabbergasted. I did doublecheck with lsmod that the right driver (nvidia) is loaded.

I even tried creating a brand new user and logging in with that account. Again fallback mode!

What next?

Well, I would say that is is a little bit better now. I could start it in virtual machines with 32 MB of video RAM (where it would have needed 1024 GB before). It worked with radeonhd out of the box and probably with nouveau as well (I don’t remember, but I guess it did).

It was a good idea though.

Delete/move everything in /usr/share/gnome-shell/extensions. If it doesn’t help, just do a clean install, select “Create Partition setup”, don’t reformat the home partition but delete ~/.config, ~/.gconf, ~/.local and ~/.gnome2 from the users’ home directory (do this before installing). In the boot loader options, add ‘nomodeset’ to the kernel options to avoid a black screen if your nvidia card doesn’t like KMS. As soon as the system is installed, add the nvidia repo and install the nvidia driver.

The extensions directory is empty anyway. Before I do a new install, trying to figure out all the extra packages I had added, isn’t there any way to track down what exactly is causing gnome-shell to fail? I have a fair number of additional packages and I’d hate to have to be adding repositories and reinstalling Maya and reconfiguring my Wine apps and development environment and so on.

My biggest worry is that I’ll end up with a still non-functional gnome-shell after a reinstall and will have wasted a bunch of time… maybe someone can log into my system remotely and try to troubleshoot for 20 mins, and I’ll send them $20 by PayPal?

I’m struggling to understand what’s going on in .xsession-errors. I’m assuming that the error is somewhere before the “Starting applet secret agent because GNOME Shell disappeared” but nearby above it I see only warnings, the “No alpha support.”, missing .gtk-bookmarks, and the " ‘net usershare’ returned error 255" stuff. Is it one of these that’s the cause? Perhaps the no alpha stuff?

I tried to run gnome-shell --replace (within a logged in session because it complains about being to unable to open X display otherwise) and I get the following:

(gst-plugin-scanner:916): GStreamer-WARNING **: Failed to load plugin ‘/usr/lib64/gstreamer-0.10/libgstdc1394.so’: /usr/lib64/gstreamer-0.10/libgstdc1394.so: undefined symbol: dc1394_iso_release_all
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
Window manager warning: Missing composite extension required for compositing

I searched for the compositing error online and it says that Xinerama can interfere with it. However, in my /etc/X11/xorg.conf that option is set to “off”, and I couldn’t find anything related in the xorg.conf.d files.

In my /var/log/Xorg.0.log I don’t see anything either. I just have stuff about my display not supporting NVIDIA stereo, but I don’t think that’s an error, right? http://pastebin.com/raw.php?i=gL15iqZs
So I’m stumped again at this point.

Problem fixed. In xorg.conf I found the following:

Section “Extensions”
Option “Composite” “off”
EndSection

But why would it have been off?! Who’s responsible? I sure never edited that file before!

You found the problem. Disabling compositing is a (clever) way to enforce fallback mode.
You have this:

$ grep -i composite Xorg.0.log.Prune
  1772.878] (**) Extension "Composite" is **disabled**
  1774.912] (II) Initializing built-in extension COMPOSITE

And I have this:

$ grep -i composite Xorg.0.log
[571857.720] (**) Extension "Composite" is **enabled**
[571858.691] (II) Initializing built-in extension COMPOSITE

Try to add this in /etc/X11/xorg.conf and see if it makes a difference:

Section "Extensions"
  Option "Composite" "on"
EndSection

You were faster. Well done. :wink:

On 2012-09-21 08:56, Prune wrote:
> After upgrading to 12.2, after restarting,

How did you do the upgrade, online or offline?

Online upgrade method
Offline upgrade method


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Online. Changed all repositories then zypper dup.

On 2012-09-22 03:46, Prune wrote:
>
> Online. Changed all repositories then zypper dup.

Did you review the rpmorig/rpmnew files?

It is doubtful that with a dup you have stale rpms, but you should check, just in case.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)