Please advise on 64Bit installation

I’m building a new computer and have questions concerning the openSUSE install. This machine will have 8 Gb of RAM and 4 hard drives. I’m going to install the OS on one of the hard drives and set the other 3 up with LVM RAID 5. On RAID I will store my files which I will make available with SAMBA and NFS to the other machines on the network. I want to use a 64 bit OS due to the amount of RAM I’m using and the fact that there is now a flash player available. I also intend to use XCFE to cut down on resources used. Here are my questions and concerns:

  1. My current 11.1 64 bit install requires me to either give permissions or mount as root via the command line to make the dvdrw, and usb drives available to user. I can’t mount as I could in 10.3 with a right click due to hal. Is there a fix or better way for this? I’ve tried editing /etc/fstab but I have several different external hard drives and pen drives and don’t really want to make an entry for each.

  2. I have both ATI and Nvidia video cards available. I will be using dual LCD monitors. Which is easiest to set up and have the best drivers? I had trouble with Nvidia and the pae kernel with 32 bit installs. Recommendations?

  3. Any other recommendations or pitfalls you see before me?

  4. Should I just use 11.0 or even 10.3 instead?

Thanks for your attention to this matter.


  1. There was an issue with cd/dvd drives and the fix is:

YAST >> Security and Users >> User Management >> “select your user” >> Edit >> Details >> Groups >> check “cdrom” and “disk” and then click on “ACCEPT”.

  1. You can but try, first the repo way. If no joy there, then try the hard way - this is almost OK. Check reports in the HCL
    Hardware - openSUSE

  2. I understand there have been some issues with samba, don’t use it myself (just secure ftp on my LAN)

If you have no other crappy OS’s installed. Have a ball, give it a go. It’s great fun

  1. Um. maybe not.
    11.0 would be a possibility.

[QUOTE=caf4926;1938943]1. There was an issue with cd/dvd drives and the fix is:

YAST >> Security and Users >> User Management >> “select your user” >> Edit >> Details >> Groups >> check “cdrom” and “disk” and then click on “ACCEPT”.

I tried this in my current install and it did not work. One of the reasons I’m posting this.


I would defiantly go for nvidia not read a lot less posts with driver issues compared to ati
The opensuse site has a lot of info NVIDIA - openSUSE



Re; In the past - I can’t comment on Gnome but in KDE3 auto mount seemed much simpler and happened without fail.
Many users are finding problems getting the hang of KDE4 - as far as auto-mount is concerned.

I can’t see the problem myself. Everything just works, even if slightly differently. There is certainly no need to issue the command from a terminal. Whatever I throw in the tray or plug in the usb it pops up in Dolphin.

FYI: I’m agree with Geoff on nvidia, but then I have no experience with ati.

My mount problems must be the result of using XFCE. But mine certainly don’t “just work”. I want this stable so maybe I’ll install KDE 3.5 and see if that takes care of the mount issues.

Nvidia it will be. I was leaning that way.


With 8 GiB RAM, whether you use XFCE, GNOME or KDE is not going to matter much. Similarly using 2 displays, rather implies you ought to be choosing the desktop based on what works best for you.

With 4 disks, if you care about performance I’d much rather use RAID 1 for most of OS, and RAID 10 for data (consider having /var there). You could stripe the non mirrored area, and use it for /tmp, or temporary download files, browser cache type thing, a fast area for unimportant transient data.

The space you apparently loose on mirroring, ought to be mostly gained back by not dedicating a whole disk to the OS, and sizing it sensibly.