PlayonLinux Does anyone have it yet 11.2

I have looked and no one seem to be working with it or wine doors which has other issues.

If anyone has it installed please share.

Just install the version for 11.1:
PackMan :: Package details for PlayOnLinux

Just remember to install wine and the dependencies it asks for
Or set up your computer as a repo, its a good idea if you want to avoid the dependency complaints.

You inspired me to try something I had almost forgotten about. Man the easy of using the software manager makes one lazy. Back in the day when I used Debian and Ubuntu I was always hand installing stuff. You always counted your blessings when software just installed and worked, now I just take it for granted that it will work. I just want to say I am truly grateful to Opensuse 11.2 it has been a very peaceful experience.

Well enough gabbing about the old days PlayonLinux 3.7.2 works great in 11.2. I am posting the howto next for all that want to use it. O and yes playonlinux is the lazy mans answer to installing almost anything in wine.

1. Install wine you may need to add the wine repo for that.
The easiest way to add it is to go to yast>software Repositories>add>Community Repositories. The wine repo is one of the community Repositories on this list.

You also need to install these dependencies of Playonlinux.


I used the playonlinux 3.6 install for opensuse 11.1 to tell me what dependencies were missing on my system.Suse 11.1 3.6 install

2. Open a terminal and configure wine with this command


XP will most likely be the OS selected (If you are using vista or windows 7 programs you may need to select that OS as your base)
2.1 Go to the Audio tab it will asks to use Alsa or what ever it believes to be best. Just okay the option offered and hit okay again to
leave the configuration window.

Now it is time to Download playonlinux.Download Page

  1. Select the Generic download option. (PlayOnLinux_3.7.2.tar.gz)
  2. Make a folder and extract the download file to the folder
  3. Open a terminal in that folder (this can be done under tools in Dolphin)
    Type ls to see that your terminal is actually in the right folder.
  4. Enter this Command
sh ./playonlinux

Do not close the terminal when playonlinux starts up, this will close both programs. Once it has installed a few fonts and other needed
programs you are finished. Now all you need to do is click install and then choose what program you want to install.

Make a menu Icon in kde 4.3

  1. Right click Kde menu icon and select menu editor
  2. Choose the folder you wish to use and click new item
  3. Enter the name (playonlinux) then go to command and select open file dialog icon.
    Open the folder you un-zipped playonlinux to and select the file named “playonlinux”.
  4. Under the Advanced tab go to work path and select the open file dialog icon. Navigate to the playonlinux folder and click okay.
  5. Now under the Advanced tab select run in terminal and enter.
sh ./playonlinux
  1. To select an icon for playonlinux returning to the General tab and to the right of name there is a square button click it and select your icon.


and by chance could you explain how to make a functional launcher in GNOME that tells it to go to the file and then run sh ./playonlinux

OK I am revisiting this again but no responses. i AM SURPRISED THE ONE-CLICK install doesn’t work or that it doesn’t show up in yast even though I have the packman repository enabled, any suggestions there??

but at least this install works but I would really like to make a short cut instead of needing to go into terminal and cd to the folder and sh ./playonlinux every time I need it??

OK I have solved this myself

in playonlinux, go to settings>environment and there is a tick for “add menu in your panel”, voila!

lol,u guys are awesome,…thanks alot for the solution :slight_smile:

Hey mates just to know… I’ve found one repository which contains latest PlayOnLinux 3.7.3 - noarch package. Hope it will help someone & that the owner of repo doesn’t mind.
Index of /repositories/home:/ocefpaf/openSUSE_11.2

thanks for the helpful link, it works but I can’t run the gui, so I used the tar.gz for 3.7.3 and that seems to work like the last one. Any idea why I couldn’t get it to run the gui with your method? Thanks