playing wma in amarok

ok. I give up soon. I’ve been trying to play .wmas with amarok but obviously I’m not doing things right. can someone provide a step by step guide for me - and adjust it as I tell you how much it doesn’t work (like the ones I found on the net didn’t work)? :stuck_out_tongue:

I’m sure someone on here is able to fix this for me. it’s incredibly annoying. vlc plays .wmas but I use amarok because… well it’s the best player I’ve ever used. and it has built in.

so any help would be reasonably appreciated. thanks :slight_smile:

ok. it is frankly IMPOSSIBLE to do this. have you ever heard this: “ obsoletes xine-lib provided by xine-lib-”? because I have. maaaaaaany times. and what’s the use of the replacement button if it doesn’t work? how on earth do I actually do this so I can watch AVIs (apparently I can’t do that either) and listen to WMAs???

I’ve tried countless of packages, like this one:
no one seems to work thanks to that error message about xine.

You neglected to mention if you are using SuSE-8.x, or 9.x or 10.x, or 11.0 ? And even if you did, I can’t give you a step-by-step guide.

But I recommend you setup your repositories with ONLY oss, non-oss, update and packman (and NO others). Guidance for doing that is here:
Repositories - openSUSE-Community

Once your repositories are setup, then install the packman packaged libxine1, xine-ui, amarok, libffmpeg0, w32codec-all. Do not use the Novell packaged versions. Ensure you have the xine engine selected in amarok.

I recommend you become more familiar with openSUSE concepts:
Concepts - openSUSE

Good luck.

OK, then remove xine-lib and try again.

errr… I tried that earlier, but no xine-lib popped up. now it did. and I removed it. and I ran that thingy… and it worked. woah. I’m amazed. something must’ve caused it to not pop up when I checked earlier. might be my terrible internet connection that made the package manager confused or whatever. avis work and I guess wmas work (I’ll test once I can get my hands on one).

sorry, my bad. thanks for the link to the concepts. I will look onto that. I’m sorry for not doing better research myself, but I’m slightly in a hurry to get everything set up and I haven’t used SUSE for about 5-6 years. I’ve been stuck with Fedora forever, but openSUSE 11.0 is about to replace it. at least on my notebook. cheers!