Playing real media in Amarok 2.x

I was able to play .rm files(real media) in amarok-1.x and also for a few days in amarok-2.x. But I guess after an update I was not able to play any .rm files. I am just not able to add any .rm files to the playlist. Not sure what the problem is. I have the phonon-xine backend installed and all the necessary codecs. Can someone help me out?
Note that I can play real media in real player without any problems.

Here are the related packages that are installed.

rpm -qa | grep amarok

amarok-2.1.1-7.6.i586

rpm -qa | grep xine

libxine1-pulse-1.1.17-1.pm.23.3.i586
libxine1-codecs-1.1.17-1.pm.23.3.i586
libxine1-1.1.17-1.pm.23.3.i586
libxine1-gnome-vfs-1.1.17-1.pm.23.3.i586
xine-ui-0.99.5-223.3.i586
phonon-backend-xine-4.3.1-3.3.i586
libxine-devel-1.1.17-1.pm.23.3.i586
xinetd-2.3.14-143.2.i586

rpm -qa | grep phonon

libphonon4-4.3.1-3.3.i586
phonon-backend-gstreamer-0_10-4.3.1-3.3.i586
phonon-devel-4.3.1-3.3.i586
phonon-backend-xine-4.3.1-3.3.i586
phonon-4.3.1-3.3.i586

rpm -qa | grep codec

w32codec-all-20071007-0.pm.1.1.i586
jakarta-commons-codec-1.3-315.5.noarch
libxine1-codecs-1.1.17-1.pm.23.3.i586
k3b-codecs-1.69.0-40.pm.43.16.i586
opensuse-codecs-installer-10.3.1-71.1.noarch
libavcodec52-0.5.20796svn-0.pm.1.5.i586

rpm -qa | grep w32

w32codec-all-20071007-0.pm.1.1.i586

Phonon must have switched backends from xine to gstreamer.

Either uninstall phonon-backend-gstreamer completely or open the System Settings -> Sound configuration window and switch the backend back to xine.

Hopefully that will fix it :slight_smile: