Playing ISO files, help, thanks.

Hi there, good morning.

I installed last week openSuse 11.1 on my Acer Aspire One netbook, and it all went perfectly fine, all working as it should, and I did it from an external USB DVD, clean installation and the only system now on the netbook.

Before that, I had Windows XP running on it, and I mostly used it for studying, CBTNuggets, using Alcohol 52% application to play the ISOs, which is the format that these came on.

I’ve tried to do this on openSuse now, but I cant find anything similar to this Alcohol 52% application.
I tried with the default programs that come with openSuse system, Banshee, Totem, and the rest, none of them can play ISOs, then I downloaded and installed VLC player, same result, cant play ISOs…

The weird thing is that if I double click on the ISO itself, Nautilus file browser opens its contents, and I can actually browse through the folders, and I found the actual videos of the nugget itself, which are in ASF format…
I was able to extract the videos with Nautilus, and put them on my Home folder, but then I tried to play the videos again with everything I could, no luck…

I really need to make this work, I use this netbook primarily to study everywhere I go because of its size, so any help/info will be greatly appreciated, many thanks :slight_smile:

I know that kaffeine is able to play dvd-iso’s but I don’t know what’s exactly in the iso’s. Take care that you install only libdvdcss from the VLC repo, all codecs and players from the Packman repo. That should be a first step, so that you can play all videoformats.
Are you sure it’s ISO’s your talking about, or are the MDF/MDS-images? I assume it’s ISO and that you have already mounted them. If not try this, in a terminalwindow:
cd ‘to folder where ISO is’
(enter rootpassword)
mount -oloop ‘full ISO name’ /mnt
You can now access the files and folders from the ISO in the folder /mnt

Good luck

You speak about playing ISO files, but it seem that you are not able to play videos.
In my deem there is no need in Linux for something like Alcohol provided that you are always able to see the content of an ISO file.
Beeing able to play any video format is a matter of installing the needed codecs from Packman.
With Packman versions of Kaffeine, Mplayer and Win32codecs I am able to play every Video file.

Hi there,

I can access the files in the ISO just double clicking on the ISO itself, Nautilus opens the ISO fine, and then I can extract the videos to a folder.
I installed codecs, but still was unable to view the videos anyway.
I’ll check all those packs tonight, and see if I get any luck…

Many thanks to both for the info :slight_smile:

Aren’t the files in wmv format? They could be DRMed.

Hi there, good night.

I’ve gone to that packman site, but there are so many things there that I dont even know where to begin…

I’ve downloaded ISOMorphin, and when tried to mount the ISO it said that it wasnt an ISO file… odd.
In the file properties it says:

Type: raw CD image (application/x-cd-image)

I can open the exact same file on any XP computer no prooblem, using Alcohol, so I suppose the file is alright.

The videos I extracted from the ISO using Nautilus are:

Type: ASF video (video/x-ms-asf)

But still cant play them at all, I’ve even downloaded MPlayer, but I dont even know how to install it…
I run the downloaded file and it uncompress it as a folder, go inside the folder and there are loads of other folders, and also loads of files, but cant see any file I can run to install it… :shame:

Getting a bit frustrated now, never thought it will be this difficult to play ISOs at all on this system, it’s so **** easy with Alcohol/XP, **** it >:(
WIll keep trying though, so more info and help needed, thanks :slight_smile:

You could try AcetoneISO package (there are both GNOME and KDE frontends). It’s something like Daemon Tools. But i still don’t know what do You mean by “playing ISO” ???

Hi there, good night.

Thanks for the quick answer, I’ll try that software and see how it goes.
What I mean by playing ISOs, I’ll put the example in Windows XP, which is what I used before:

I’ve got an ISO file with CBTNuggets on it, I mount the file with Alcohol 52%, and then play its contents with a browser, in XP case it was Internet Explorer.
The CBTNugger has explanatory videos inside, in a web menu where you can choose which one you want to see, and it also says the lenght of it, all inside the browser as you were online, I suppose is HTML?

Alcohol itself doesnt “play” the ISO file, it just mounts it, and then I play it with the browser, or the DVD player in case I’m mounting a film.

I hope I explained myself a bit better this time, and thanks again for your help, I’ll try that Acetone program later :slight_smile:

Hi there,

Well, went to the Packman web site, click on the button to 1 click install, but now I cannot find the app, it gave me a couple of errors when trying to install it…

I downloaded it then, and when I run it from the desktop this is the error that comes up:

Package /home/JLCSan/Desktop/ could not be installed.

Subprocess failed. Error: RPM failed: warning: /home/JLCSan/Desktop/ Header V3 DSA signature: NOKEY, key ID 9a795806
error: Failed dependencies:
pinentry-qt is needed by
fuseiso is needed by
p7zip is needed by
kdebase3 is needed by
MPlayer is needed by

At a lost now lol!

Why do You install it from a file and not from the Packman repo?? Packman is almost mandatory to have in repo list.

Anyway,if you install from a file then it is kinda obvious what you need to install to satisfy dependencies when you see a message like " x is needed by y"

I’ve chosen to extract the rpm file instead of running it, and after the extraction I got a new folder on the desktop, in which I can browse to the Acetoneiso2 bin file.
I can use the program now, but when I mount the ISO file it does nothing, the Nugget itself doesnt come up or anything, in the options of the acetone program I choose VLC as the media player, but no luck anyway, still wont play it…:frowning:

What Desktop Environment are You running? GNOME or KDE? I think this is just a matter of adjusting autorun options.

After some twiddling with VLC there is an option to play files with extensions that you say are on the CD. Open VLC, go to Media, then Open Disc then down there “Show more options” on left from Extra media click Browse and point it to the files on the disk.

By the way, it’s better to download VLC from the repo because it will download many necessary packages to decode the audio/video files. If you install from file you may miss many files which you’d need to watch the movies.

P.S. You know, repo is there for a reason:)

you are doing it ALL wrong…you are thinking Windows[tm], the OLD
FASHIONED, labor intensive way…

here there is (usually) no need to UNPACK compressed files…here you
don’t “go to that packman site”, instead you go to (in this case)
and follow your nose…

in other cases you (and depending on which way you like best) add a
software repository using either YaST or zypper, and then let one of
THOSE do all the the rest of the work (by clicking on what you want in
YaST or typing what you want in zypper)…

READ man!

which includes links IMPORTANT to your understanding of how we do it
here–this will save you LOTS of time…because instead of asking here
and getting a truncated (and possibly incorrect) answer you can
actually read about, and do it the RIGHT way (or one of several right

Basic openSUSE concepts: for the Windows users migrating to openSUSE

Repositories - openSUSE-Community

soon you will be having lots of fun and lots less
frustration…playing an iso should be drop dead simple…and, it will
be once you stop trying to do it the WRONG way…well, maybe not wrong
but certainly not the way that works here…

ps: even when you are forced to download an RPM, still it is unneeded
to “unpack” it, just right click on the file, select “Actions”, select
“Install with YaST”, give root password…sit back and WATCH real
innovation in process…

Redmond might get as advanced in Windows 8…


VLC player

right click .iso open with vlc

Man! You guys need to stop telling people that they are lousy drivers before they even get in the bloody car!!

The guy is new, he doesn’t understand ANYTHING about repos or .rpm files.

Please, PLEASE, try to explain things as if the OP knows nothing. You were all new once, remember that?

OK, to the OP:

I have to go to work so can’t write any more this morning, but if you have no luck during the day, I’ll help you later on. Persevere, and don’t be put off with all this nonsense, it’s fairly easy to do what you want.

Growbag, you’re right. I and other people failed that he is new to this business :slight_smile:

I guess after installatio there should be a pop-up window explaining all the differences and how to do them or at least pointing them to an online tutorial.

> Please, PLEASE, try to explain things as if the OP knows nothing. You
> were all new once, remember that?

i did–or at least that was my intentnion!

the problem is the answers he was getting was not helping BECAUSE he
didn’t have the background to use them…

i provided LINKs to enough background to get him started…and,
hopefully OFF the old download-a-zip-unpack-double-click-FINISHED
mantra he was trying…

> OK, to the OP:
> it’s fairly easy to do what you want.

it is REALLY easy…but, different from the way you are used
to…sooner you read/learn how to do it here, the sooner you have more
fun here…


Playing iso images isn’t all that complicated folks, xine can do it, mplayer can do it…

xine dvd:/path/to/your/DVD/image.iso

mplayer dvd://1 -dvd-device /path/to/your/DVD/image.iso

Hi there, good afternoon.

Well, first of all, many many thanks to everybody who is trying to help/helping me here.

I must say I’m fairly new to Linux (apart from using RedHat 8 in the past for a bit), so I know I’ve got a lot to read/learn here, problem being I havent got much time for that at the moment, but I’ll honestly try my best to make this work.

Last night I got really frustrated (coming from a “Windows world” is something I was expecting to happen sooner rather than later…), but in the end I could install AcetoneISO from the Packman site, and it installed all codecs with it.
I could then mount the ISO with ACetoneISO, and open it with Firefox, see the contents of it with all the links and everything, so that was a huge step forward for me :slight_smile:
Still, when I clicked the links on it to watch the actual videos, they wouldnt play, but I suppose that should be easier to fix, installing some more codecs or any tweaking within Firefox should solve that issue I hope, so I’m much happier now :slight_smile:

I have to reckon I dont know nothing about how this all works, Yast, rpm, tz, Repos… again, I’ve got a lot to read and learn lol!
I’ll use the links you put here and start reading there, hopefuly I’ll get a slight notion of how this all works soon, and start using it as my everyday OS.

I’m at work at the moment, so I will try something else later on this evening, and again many thanks to you all for your help and patience :slight_smile: