players crash on .ogv files?

Running OpenSuSE 11.0, Gnome desktop. I have Totem, Mplayer (packman) and Realplayer installed.

I have made a couple of tutorials using recordmydesktop from the packman repo. It saves them as .ogv files, but none of the above players play it? Realplayer errors out with a codec problem, Mplayer and Totem start, but die quickly.

I thought that the .ogv file would play natively? Perhaps, the problem is with the way recordmydesktop saves the files?


bertman, take a look here on what it has to say about ogg (theora is for ogv). Multimedia - openSUSE-Community

If you can post a small sample some where of one of the videos that is giving you problems, I can try test your claim, but I have not had ogv problems.

Old CPU,
I will research a place to upload, and give you a link.

I had all of this stuff already installed manually, but performed the one click option anyway. It gave the same result. what’s interesting, is that the file will play on this 10.3 machine just fine.


Old CPU,
Here is a link…

click here

Thanks. It plays on my openSUSE-10.3 (KDE-3.5.7) and my openSUSE-11.0 (KDE-3.5.9) with no problem with vlc, smplayer, and xine-ui. In all cases I was using strictly packman packaged versions of those applications (except for 11.0 where I had openSUSE libtheora and libvorbis). Specifically on my 10.3 PC:

oldcpu@stonehenge:~/temp> rpm -q libxine1 smplayer MPlayer vlc libvorbis libtheora0

and 11.0 PC:

oldcpu@stonehenge02:~> rpm -q libxine1 smplayer MPlayer vlc libvorbis libtheora0

Old CPU,
Here is my output
package smplayer is not installed
package vlc is not installed

I don’t think I need smplayer, and vlc…those are just other players.


If it does not play in mplayer, then clearly you are missing an important app to provide it, … but I do not know what you are missing. Some other apps I have are:

oldcpu@stonehenge02:~> rpm -q libogg-devel flac vorbis-tools

Also, if you are going to have MPlayer installed, I highly recommend you install smplayer. Try it, you can remove it if you don’t like it.

The same is true for libxine1. Ensure you have xine-ui installed, as it is very handly for testing if a sound problem is the cause of the xine engine.

Also, please confirm that you did NOT force the install of any of your multimedia apps.

Old CPU,
I think I figured it out…
On a hunch, I turned off the effects. Intel G33 GPU onboard video. I think it uses aiglx, perhaps there is a conflict.
It plays fine on my daughters machine running SuSe 11.0 and desktop effects…Nvidia vid card.


Old CPU,
No, I did not force install any apps. Just cleanly, through YaST.

Maybe this is the “old” x11 vs xv problem when special desktop effects are in use.

If you have “special desktop effects” enabled, switch your players to “x11” (from “xv” or auto) and see if that works.

If you do not have “special desktop effects” then “xv” (xvideo) should work fine.

Old CPU,
While I did not have any special effects enabled, I took your advice, and under (Gnome) Control Center, Gstreamer Properties, I changed the Video setting to be X11, no xv. That seemed to allow it to play with Totem!

Thank you!


Congratulations! Thank-you for sharing your solution.

… is it just me, or are these things becoming more complex? ( maybe its just my old age perspective talking here ). There was a time when this seemed to be much simpler. :rolleyes:

Old CPU,
More complex I think…
This computer gets special attention, as it is being shipped to my folks 1,300, miles away, and will be moving them from an XP powered machine, to SuSE Linux. It needs to operate as well as possible.

I’ve read lots of your posts, and you have helped me before.

Thanks again!


Ok, good luck. I support my mother’s PC in a different continent, … some things I did to make it easier (for me):
a. put a firefox icon on the desktop, where if my mother clicks on it, she is immediately taken to a web site that gives her the IP-Address of her PC in very big letters. That way she can always tell me (over the phone) her IP-Address.
b. put a cron job on her PC, that runs every 15mintues, that will map her IP-address to a dyndns account, and create a static URL link to her IP (ie something like
c. opened up port#22 and #5900 and #5901 on her PC so I can ssh, vnc and nx into her PC.
d. ensured all fonts were VERY BIG (my mother likes big fonts)
e. set up her PC that it always boots to openSUSE Linux by default (she also has winME and winXP on her PC). Hence I can reboot when necessary, and still get my connection back after the reboot is over.
f. ensured ntfs-3g was working properly, so I can access her winXP ntfs partition with read/write, from Linux.
g. setup Smart Package Manager such that a copy is retained of all installed rpms (that way I can easily roll back a release if possible).

If your parents have a router, you may have to help them over the phone portforward port#22 (or some other port) on their router to the port#22 on the PC. For guidance on that: - Free Help Setting up Your Router or Firewall

Old CPU,

I’ve already taken care of most of those things.

What is the port #22 item for?

As for the dydns, I had thought of that, but hadn’t set it up. I think there is a package in the build service that will do that.

She should be using SuSE all the time, and have xp set up with Virtualbox for doing her taxes (USA).




yaloki taught me how to setup the dyndns over IRC chat, back in 2007.

I posted here (from the SLS archives) my implementation of what I installed on my mother’s PC (which is my poor implementation of what I remembered from from yaloki’s teachings):
setting up dyndns for parents PC

Some router’s have the capability to update the dyndns, hence if your parents router have that capability, you can set that up instead.

OGV files can be directly played in browsers like Firefox and Google Chrome. To get more information about how to play and convert OGV file, go to Google and you can find a solution.