Plasmashell using more and more CPU

I’m having a problem with plasmashell’s CPU usage on one laptop (HP Probook 470 G5).

Basically it looks like this: the longer I use my computer the more CPU is being used by plasmashell and X processes. After rendering a video in kdenlive the CPU usage is noticeable although it reaches only 15% (in ksysguard) which is unusual but I think that kind of usage shouldn’t be noticeable. Rebooting or relogining fixes the issue for a while.

It all started after reinstallation of openSUSE, /home partition was not formatted and all settings are being used in this new installation.
Users desktop is configured to two external monitors (laptop monitor is turned off) and there are 4 panels per monitor (I’m not sure if that matters).

Things I tried to fix this issue:

  • create new user, which helped probably until setting up the desktop (no setting were copied)
  • remove all plasmoids (excluding the standard ones like app launcher, taskbar and tray)
  • disable baloo file (which AFAIK is useless on SSD anyway)
  • update Plasma to 5.12

None of it fixed the problem, disabling baloo made the plasmashell take longer to cross the line when CPU usage is noticable.

Worst thing is I have absolutely no idea how to track the problem. Maybe you can help me?

I see this occasionally in my daughter’s laptop. Although it is not the only reason- there are outstanding bug reports on this since years - widget animations increase plasmashell cpu usage considerably. For example, when you are copying a large file with a progress bar in the notification widget, etc.

What fixes it, temporarily, is to quit and restart the user session.

I’ve looked hard for a solution about a month ago, but no joy…

I have slowdowns (not higher CPU usage) with Broadwell graphics, untill I upgraded Mesa/Xorg from OBS. So maybe it is kernel / mesa / xorg related?

Animation slow down should be resolved according to KDE bugzilla. I experienced it last time maybe year or two ago.

Try disabling the Compositor. Systemsettings - Display and Monitor.

This happened a couple of times at the beginning of this month, but after restarting the session some two weeks ago it hasn’t happened again. My daughter usually suspends the laptop, she rarely (never) end the session or reboot.

Ok, today I tried to downgrade mesa, xorg and kernel. None of it helped.
I also tried disabling the Compositor which didn’t help either.

  • I left 4 panels overall (2 on each screen)
  • changed app lauchers from full screen to the default ones
  • I disabled all applications set in autostart

Nothing helps.
I created another user and checked ksysguard. Nothing is happening, all processes are using less than 1% CPU and on normal user, after logging in, plasmashell is using 1-2% and same for X and it won’t go down only higher.

I’m thinking if it’s time to hit KDE forums…

What are your system resources?

One classic cause for high CPU usage is when you have inadequate memory, causing swapping which is when the CPU usage goes up (and your disk is thrashing).

I personally recommend 6GB RAM to run KDE/Plasm comfortably, 4GB is really living on the edge unless you turn off bells and whistles.

If you have low RAM and can’t upgrade, then I’d recommend a “lighter” Desktop like LXQt (particularly for former KDE Users) which will enable you to run heavier workloads with less concern for running low on resources.


It has Intel Core i5-8250U 1.6 - 3.4 GHz and 8GB RAM but that shouldn’t be a case because that problem appeared after reinstallation of openSUSE. Before that everything was fine.

Anyway, at the end of work today I discovered what was causing this problem and it’s just so stupid I can’t believe it. It turned out to be an analog clock widget with second hand turned on.
After disabling the second hand everything went back to normal. Strange thing was that the longer the plasmashell was turned on the more CPU it would consume. I’m gonna file a bug report tomorrow.

This thread can be marked as solved.

That’s what I suggested in post #2, wasn’t it? Note it happens not only with your clock but with other widget animations. Probably how much CPU it eats depends on the intensity/complexity of the animation…

I mentioned in my first post that I tried removing all widgets, I just haven’t noticed second hand in clock and wasn’t even expeting clock to use that much CPU because clock is used everywhere and redrawing one line every 1 second shouldn’t consume more and more CPU.