Plasmashell and X consumes CPU and slows PC

I have been having problems with KDE, Plasmashell and Mesa.
Even though I seems to have found the solution to my problem I wanted to post this to share my situation and the solution.

My system slows down after a while. Very poor responsivenes. Switching between applications is very sluggish. Even interaction in my web browser, scrolling, clicking has very slow responsivness.

When this happens both plasmashell and X uses a lot of CPU, not the entire CPU, but still a lot.
plasmashell can run at ~100 and X at ~50-60.

When this happens I need to kill plasmashell and restart it. Then my system is fast again.

I have experienced this problem on two PCs.
My home server
Intel 2 Core Quad Q9450
Graphics: NVIDIA GT 610
Monitors: BenQ 1920x1080

My work laptop
CPU: Intel Core i7-4800MQ
Graphics: Intel and NVIDIA Quadro K2100M.
Monitors: Laptop 1920x1080, (primary) Samsung 1920x1200, Samsung 1920x1200

The laptop is dual graphics with both Intel and Nvidia, but I am only running with Mesa on it. My server is running with Mesa and Nouveau. I have previously run the laptop with Nvidia Bumblebee, but experienced the same problem with it.

The laptop have VirtualBox VM running occasionally. The server does not have any VMs.

The server has it much worse, as it becomes almost unresponsive after just one day or even less. My laptop I can use for several days before it becomes sluggish. Perhaps because it has a more powerful Intel CPU.

I need to figure this out. I am quite tired of this. Have struggled with this problem for about a year now. Killing plasmashell has worked as a workaround, but I can’t keep on doing that.
Am I the only one having trouble running KDE on Mesa. I have searched and could find anything relevant that was current.

Mesa 18
Kernel 4.16
Mesa, X and Kernel are installed on Leap 42.3 using the following repositories:
I have experienced this with older Mesa and Kernel also.
Package xf86-video-intel package is not installed.

My laptop is running Qt5.9 from Leap, while my server is running Qt5.10 from

Did find some other discussion around this problem, but no solutions.

Have no image background. Just black.
Have running a few desktop widgets for CPU, Memory and Network usage.

I have third PC (also Leap 42.3), running Intel i7-6850K and NVIDIA GTX 1080. It is running on NVIDIA proprietary drivers and is never sluggish. This runs on vanilla Leap (no newer Mesa, X or Kernel).

If anyone can help me figure this out I would appreciate it. If there is any commands I can run for more information, let me know.

If I cannot find a solution I will attempt to reinstall fresh with Leap 15 when that comes out.

After writing this I tried some solutions mentioned in the bug reports. I have disabled “Show Seconds” on clock, and removed all Desktop widgets.

I have not been plagued with sluggish system since I tried that.
A few days later, still fine and no sluggish behaviour. I then added on desktop widget, the network monitor. One day later my system was still responsive.
Two weeks later, still fine.

Seems like the Digital clock with seconds caused the Plasmashell to spin out of control. Though Only with MESA/Nouveau. I never had this problem running on my PC with NVIDIA.

On my Desktop I have an Amd Cpu and an Nvidia gt 610 with the Nvidia proprietary drivers installed equal to the one you have on the Server, and it’s never slow, actually it’s the fastest computer I have.
It is known that laptops with the dual card are problematic, and if you can not configure Bumblebee or turn off one from the bios the cards remain active both, generating slowdowns.
I use Gnome, but this can not make any difference

It makes a difference. I use KDE and it is its plasmashell that consumes a lot of CPU (and it takes X with it).

Start by installing the proprietary drivers where you have the 610 gt, then see how it goes

Show us all your repos:

zypper lr -d

Just to confirm the information at the very beginning of this post, please show us the output of:

 > Xorg -version
 > glxinfo | grep -iE 'OpenGL renderer|OpenGL core profile version|OpenGL version|OpenGL ES profile version'
 > plasmashell --version
 > kf5-config --version
 > uname -a

From what you’ve originally posted, it seems that, you’re using versions which behave properly with Leap 15 and/or Tumbleweed.

Was that with, or without the “Mesa-dri-nouveau” package installed? Without there is a significant increase in CPU utilisation, as I found from my own experience: 381495 – Significant increase in CPU utilisation when "Show Seconds" enabled.

Despite the warning when installing “Mesa-dri-nouveau” I’m using it (and have used for quite a long time) with no problems, albeit with a quite elderly 8600GTS (G84) video card and not particularly graphic intensive applications.