Plasma5 update, black screen

I cannot get past an update to Plasma 5 and KF5. After I upgrade and restart the computer I get a black screen with a cursor. KRunner is working and I can run an application with it but they don’t have any decorations and buttons. I can’t figure out what is wrong. I rolled back to a backup I had. I managed to save an xsession log and journactl log. However I don’t understand them.
My Apps are now 15.04.3, KF5 5.12, Qt 5.4.2 and the update is to 15.08, 5.13 and 5.5
I tried another accound, deleting .cache, .kde, .config or .local and nothing works

journalctl -n 300

/usr/bin/plasmashell: symbol lookup error: /usr/bin/plasmashell: undefined symbol: _ZN8KWayland6Client8Registry20plasmaShellAnnouncedEjj

Install kwayland. You seem to still have the older libKF5KWaylandServer5 and libKF5KWaylandClient5 packages installed.

And/or do a full switch to the KF5 repo as instructed here, that should install it automatically:

Thank you very much. It worked.
I thought I had clicked on the vendor change thing befor but apparently not.

That was a recent change: libKF5KWaylandServer5 and libKF5KWaylandClient5 were merged into kwayland with version 5.3.95.