Plasma5 no longer starts by default

After adding multimedia files, gnome got installed by mistake and kde/plasma5 desktop was removed.

That was corrected and now I can select plasma5 when I login. But I want to have be the default choice whenever I start up or login.

I do not seem to find how to do this

I’m not sure how that happened. Usually zypper gives clear conflict messages about removing software.

That was corrected and now I can select plasma5 when I login. But I want to have be the default choice whenever I start up or login.

Normally, you login to a DM screen (DM=displaymanager). Typically this is either SDDM or GDM. Both of those remember the destop selected for the most recent login, and it becomes the default for the next login.

With GDM, this is a per-person default. With SDDM, this is a default for all users (until somebody chooses a different desktop).

Should have been posted as 15.1, but is resolved in an event.

I’ve edited the thread prefix for you, and glad to read that it is now resolved.

Please use the YaST Software Manager – there are Patterns in there for the GNOME and KDE Plasma user environments. <https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha-yast-software.html#sec-yast-software-qt>
[HR][/HR]Yet another quiet hint:

Use YaST!

Please use the YaST Software Manager to resolve this – there are Patterns in there for the various user Desktop environments:
<https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha-yast-software.html#sec-yast-software-qt>
<https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha-yast-software.html#sec-yast-software-search>

This will be a little bit more difficult – as nrickert mentioned, GNOME uses “gdm” as the Display Manager of choice; KDE Plasma uses “sddm” …

  • Once again with YaST – no Handbook for this – YaST section “System” – “/etc/sysconfig-Editor” – section “Desktop” → “Display manager”:

[INDENT=2]Value: “DISPLAYMANAGER” – set it to the value “sddm”, save and exit and then, reboot.[/INDENT]

  • Caveat: you have KDE Plasma components installed including, the Display Manager: sddm

Once you’ve returned to KDE Plasma as being your preferred Desktop environment, use the YaST Software Manager to clean up the GNOME bits and pieces which you don’t need.

  • Please be aware that, the Gtk environment is needed by default for applications such as Firefox and LibreOffice – therefore, even if your preferred Desktop is KDE Plasma, there are parts of the GNOME environment installed by default, to support the Gtk applications mentioned – please, please, read and understand everything
    the YaST Software Manager pops up for you to review when removing bits and pieces of the GNOME Desktop environment …

This isn’t quite right. Setting DISPLAYMANAGER in “/etc/sysconfig” editor won’t do what is needed.

Instead, use (at the root command line)


update-alternatives --config default-displaymanager

Refer to the wiki page this (using “update-alternatives”)
https://en.opensuse.org/SDB:Change_Display_Manager

Thanks, many, to all that offered assistance.

I did manage to get back to my preferred display and all is as it was. “Many such journeys are possible”, to steal a line from an original Star Trek program.

Removing the un-needed Gnome stuff I will approach with Great Care and Trepidation. But not tonight, I think.

Just leave it there. It isn’t worth the trouble of removing it.