Plasma5 disappears

I just invoked

zypper up

and after it completed with no errors I re-booted. When the login screen appeared only IceWM was available to start not Plasma5 previously used as default. Where do I start to diagnose the problem so I can go back to Plasma5? This is my list of locked applications which has not changed for some time.



#  | Name                         | Type    | Repository
---+------------------------------+---------+-----------
1  | multimedia                   | pattern | (any)     
2  | imaging                      | pattern | (any)     
3  | apparmor                     | pattern | (any)     
4  | samba                        | package | (any)     
5  | kdepim-apps-libs-devel       | package | (any)     
6  | office                       | pattern | (any)     
7  | kdepim-apps-libs             | package | (any)     
8  | kdepim-addons                | package | (any)     
9  | kdepim3-mobile               | package | (any)     
10 | kdepim3                      | package | (any)     
11 | kdepim3-devel                | package | (any)     
12 | kdepim-runtime               | package | (any)     
13 | kdepim3-kpilot               | package | (any)     
14 | kdepimlibs4                  | package | (any)     
15 | kdepim3-notes                | package | (any)     
16 | kdepim3-time-management      | package | (any)     
17 | digikam                      | package | (any)     
18 | amarok                       | package | (any)     
19 | libreoffice-impress          | package | (any)     
20 | libreoffice-calc             | package | (any)     
21 | libreoffice-calc-extensions  | package | (any)     
22 | libreoffice-draw             | package | (any)     
23 | libreoffice-filters-optional | package | (any)     
24 | ksudoku                      | package | (any)     



Thanks in advance.

Check that the package plasma5-session is installed, this contains the session file that makes Plasma5 appear on the login screen.

But it shouldn’t just “disappear”, especially not if you run “zypper up”.
Even if it would have to uninstall something because of a conflict, it would ask you before.

What repos are you using exactly?

zypper lr -d

plasma5-session was missing although I never specifically deleted it. I re-installed it. Here are my repositories…

linux-zwoz:/home/ion # zypper lr -d
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias                            | Name                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                            | Service
--+----------------------------------+----------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------+--------
1 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/          |        
2 | download.opensuse.org-oss        | Main Repository (OSS)      | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/              |        
3 | download.opensuse.org-tumbleweed | Main Update Repository     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                |        
4 | http-ftp.gwdg.de-23809ee1        | Packman Repository         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/ |        
5 | http-opensuse-guide.org-6857c33c | libdvdcss repository       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/            |        
6 | openSUSE-20161226-0              | openSUSE-20161226-0        | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/              |        
7 | repo-debug                       | openSUSE-Tumbleweed-Debug  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/        |        
8 | repo-source                      | openSUSE-Tumbleweed-Source | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/       |   

All icons in my panel are missing graphiics but that shouldn’t take much to correct. Thank you for the assistance.

you will have less problems on tumbleweed in general, if for updates you use: zypper dup --no-allow-vendor-change