Plasma/X login interesting issue

Hi all,

I recently got a new laptop (Lenovo Yoga 520) and I have cloned my \home partition from my old laptop (which runs Leap 42.2 flawlessly) to the new one running Tumbleweed in order to take advantage of the 2-in-1 with stylus functionalities.

Every driver and hardware seems to be working fine, however a rather interesting issue appear when I reboot/shutdow and try to login again. After the splash screen the display keeps black with only the mouse arrow (which moves normally).

What I have tested that didn’t work:
1- I can login to IceWM, but sometimes I’m unable to run any application. However, after logging out and logging in to IceWM 2 or 3 times the applications come back to normal on IceWM environment;
2- Tested multiple kernels 4.9 LTS , 4.11, 4.14 ;
3- Deleted ~/.cache and reset ~/.config to defaults;
4- Tried to “killall plasmashell” and “kstart plasmashell”, but the usual message about exporting to display appears;
5- Tried different variations of poweroff, shutdown and reboot commands ;

The only workaround that has worked until now:
1- On login screen after a reboot/shutdown I log in outside Plasma/X using Ctrl+Alt+F1, then I come back to GUI login screen with Alt+F7 and type my password. It works everytime!

I would like some help here.
Any idea on what might be the cause of this issue/bug?


Graphics hardware details?

/usr/sbin/hwinfo --gfxcard
12: PCI 02.0: 0300 VGA compatible controller (VGA)                           
  [Created at pci.378]                                                       
  Unique ID: _Znp.dmN9TBhtxsA                                                
  SysFS ID: /devices/pci0000:00/0000:00:02.0                                 
  SysFS BusID: 0000:00:02.0                                                  
  Hardware Class: graphics card                                              
  Model: "Intel VGA compatible controller"                                   
  Vendor: pci 0x8086 "Intel Corporation"                                     
  Device: pci 0x5916 
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x3987 
  Revision: 0x02
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xb0000000-0xb0ffffff (rw,non-prefetchable)
  Memory Range: 0xa0000000-0xafffffff (ro,non-prefetchable)
  I/O Ports: 0x3000-0x303f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 125 (273794 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00005916sv000017AAsd00003987bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Primary display adapter: #12

Try creating a new user and then test the behaviour with that user account. Any different?

1: video driver details?

# inxi -G -c0

2: display manager in use?

# ps -A | grep dm


As logging in as a different user worked, I tried to change permissions recursively of \home folder to default.

It seems that some config files was with read/write permission only for the owner and the rest was set as forbidden.
So now I think the problem is solved.

Thank you all :slight_smile:

Glad to have been of help. :slight_smile: