Plasma Workspace crashed on startup

Hey guys, the computer was working earlier this morning, and I just shut down, turn it on a few hours later and it gave me this message.

The application plasma workspace (plasma) crashed and caused the signal 11 (SIGSEGV)

I already looked up a few of the other threads, but I still don’t quite understand what to do right now.

Login with your username and password to the CLI and do this:

mv /home/username*/.kde4 .kde4old

replace username* with your login username
Then try startx

If it still fails. Login as user, switch to su and try running

zypper ref
zypper up

Method 1: I don’t quite understand it. CLI?

Method 2: Just finished it, still doesn’t work, the screen is still pitch black. Will retry.

do this

restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
At the login enter your username then your password


mv /home/username*/.kde4 .kde4old


Worked, much thanks.

Though, I wonder, is entering “3” in the boot arguments space really necessary? It looked just like accessing the console from the log-in page.

Console from login would have been fine. Sorry for the run around.
Happy it sorted it.
Anything you need from previous settings is in .kde4old