Plasma use more memory ?

When I start the laptop, at first login with TW+KDE plasma, a few weeks ago, it use tho show that I used about 450M of memory.
Now when I start, it show I use 1,5G. Any idea why ? I haven’t changed nothing else other than regular updates.

I check with “free -h” in the shell. I haven’t find why yet. Any clues ?


You probably have KDE set to resume your last session. So the more windows you open, the more memory it will take.

You might want to try configuring it to start with a clean session. And then see what it uses when freshly booted.

I went to the KDE system configuration panel => Start/Stop => Desktop session => and checked “Start with an empty session”. I did log out and reconnect, but no change at all. If I take a look at memory with ksysguard, it shows I actually use 1,4G of memory and 0M of swap. The first memory hungry process is mysqld with 176M (used by akonadi), the second is Plasma with 140M, then latte-dock with 65M. Those are not very that high and might be “normal” ? but for the moment I can’t pin a single process that would eat a lot of memory.

Thank you for pointing the last session restore, I had forgotten this one.



For me, the big memory gobbler is “firefox”.

I have tried to reduce memory of KDE plasma by following suggestion from : I use the browser for my mail, I also have delete all my mailboxes in Kmail and completly reset akonadi by stopping services and deleting akonadi .config files.

I have stopped akonadi, baloo, and a few other services I don’t use really.

Memory usage has lowered to 850M now, but it think it is still quite high for running an empty desktop…

I have had also a few crasches from plasma since we are on 5.20 most related to wayland/X11.
It look we cross few unstabilities with this new version.

Any suggestions to get back to lower memory usage ?


In my experience KDE isn’t exactly memory efficient, and as @nrickert said, Firefox is quite hungry. Unless you’re low on physical memory I wouldn’t worry too much about it.

FWIW for comparison:

paul@HP255G7:~> free -h
              total        used        free      shared  buff/cache   available
Mem:          7.4Gi       1.2Gi       5.1Gi        64Mi       1.2Gi       5.9Gi
Swap:            0B          0B          0B


1.5Gi doesn’t seem like a huge amount of memory. I really wouldn’t worry about it.
I run a fairly lean install of plasma and still get this

farcus@linux:~> free -h
              total        used        free      shared  buff/cache   available
Mem:          7.6Gi       1.2Gi       4.8Gi       212Mi       1.6Gi       6.0Gi
Swap:         2.0Gi          0B       2.0Gi

May be it’s OK for the high memory, but it doesn’t explain why plasma 5.19 used 500M while plasma 5.20 need 1,5G for doing essentially the same ???
I would like to understand why this is happening. Why is plasma 5.20 so hungry of memory ???

I’m not seeing much difference between plasma 5.19 & 5.20 . . .
In fact, my post above was using plasma 5.19
I’ve just updated to 5.20.1 now and this is where I’m at . . .

farcus@linux:~> free -h
              total        used        free      shared  buff/cache   available
Mem:          7.6Gi       1.3Gi       4.6Gi       209Mi       1.7Gi       5.9Gi
Swap:         2.0Gi          0B       2.0Gi

One of my more antique systems, immediately after reboot and log in to KDE desktop.

Operating System: openSUSE Tumbleweed 20201024
KDE Plasma Version: 5.20.1
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Kernel Version: 5.8.15-1-default
Memory: 3.8 GiB of RAM

paul@Orion-07:~$ free -h
              total        used        free      shared  buff/cache   available
Mem:          3.8Gi       426Mi       2.2Gi        11Mi       1.2Gi       3.2Gi
Swap:         4.0Gi          0B       4.0Gi

As already said, unless you’re low on physical memory or your (higher) memory usage is preventing the normal use of your machine, I wouldn’t worry about it. Memory is, after all, intended to be used…

Plasma readily adapts to what is available. This is a fresh boot with Firefox and Konsole only:

3400G:~ # free -h
              total        used        free      shared  buff/cache   available
Mem:           29Gi       1.9Gi        25Gi       126Mi       2.3Gi        26Gi
Swap:            0B          0B          0B
3400G:~ # 

Speed of a machine depends on all of CPU, RAM and Disks. With most of the machines I have seen recently the bottleneck is RAM and Disk. The current one has:

3400G:~ # inxi -SMCDm
System:    Host: 3400G Kernel: 5.9.1-1-default x86_64 bits: 64 Console: tty 1 Distro: openSUSE Tumbleweed 20201026 
Machine:   Type: Desktop Mobo: Gigabyte model: B450 AORUS ELITE v: x.x serial: N/A UEFI: American Megatrends v: F51 
           date: 12/18/2019 
Memory:    RAM: total: 29.32 GiB used: 2.65 GiB (9.0%) 
           Array-1: capacity: 128 GiB slots: 4 EC: None 
           Device-1: DIMM 0 size: No Module Installed 
           Device-2: DIMM 1 size: 16 GiB speed: 2133 MT/s 
           Device-3: DIMM 0 size: No Module Installed 
           Device-4: DIMM 1 size: 16 GiB speed: 2133 MT/s 
CPU:       Topology: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 type: MT MCP L2 cache: 2048 KiB 
           Speed: 1303 MHz min/max: 1400/3700 MHz Core speeds (MHz): 1: 1258 2: 1279 3: 1303 4: 1261 5: 1260 6: 1266 7: 1269 
           8: 1261 
Drives:    Local Storage: total: 2.50 TiB used: 304.55 GiB (11.9%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
           ID-3: /dev/sdc vendor: Seagate model: ST2000DM001-1CH164 size: 1.82 TiB 
3400G:~ #