Plasma schmiert beim Hochfahren ab - Debug-Package kann nicht installiert werden, da fehlend

Hallo,

seit ein paar Tagen erhalte ich beim Hochfahren des Systems eine KDE-Fehlermeldung:

Ausführbare Datei: plasmashell PID: 1951 Signal: Segmentation fault (11) Datum: 18.02.23 15:15:33 CET

Ich wollte den Fehler melden und vorher Debug-Symbole installieren, aber das scheitert (vermutlich) daran, dass es ein Problem mit der Debug-Package gibt:

Repository ‘Update Repository (Debug, Non-OSS)’ ist ungültig.
[repo-debug-update-non-oss|http://download.opensuse.org/debug/update/leap/15.4/non-oss/] Keine gültigen Metadaten bei dem festgelegten URL gefunden
Verlauf:

Jemand eine Idee?

Gruß

Gemäß den zu findenden Informationen gibt es für Non-OSS keine update-debug Pakete…seltsam
https://en.opensuse.org/Package_repositories

http://download.opensuse.org/debug/update/leap/15.4/

Und? Hast du mal in den update non-oss Ordner geschaut? Da gibt es keine Pakete…
Erkennt man auch wenn man auf das Datum der letzten Änderung schaut…2021

Außerdem wird dieses (invalide) repo gar nicht benötigt, um die Debugpakete für ein crashendes Plasma zu installieren…

Weiterhin ist das korrekte repo für non-oss dieses, da es für die updates gar keine debug Pakete gibt.
https://download.opensuse.org/debug/distribution/leap/15.4/repo/non-oss/

Also einfach mal deine Repolist aufräumen…

Meinst du, ich trage da einfach irgendwas ein? Die Liste wurde so angelegt bei der Installation.

Die Frage ist zudem, warum in dem Verzeichnis http://download.opensuse.org/debug/update/leap/15.4/ überhaupt ein non-oss-Unterverzeichnis existiert, wenn es keine Files dafür gibt.

Da die Updates auf meiner Kiste bisher fehlerfrei durchgelaufen sind, gab es diesen non-oss-File vermutlich einmal…

Wenn man sich auch nur dezent mit diesem Repo beschäftigt, wird man eine überaschende Entdeckung machen. Dieses Repo wird so gut wie gar nicht verwendet, da es für Debug non-oss Update so gut wie nie Pakete gibt. Für Leap 15.4 gibt es bisher gar keines, deswegen ist das Verzeichnis leer und wird von Zypper als invalide gekennzeichnet. Bekommt man sehr einfach raus:

Leap 15.1: Nur 3 Pakete über die gesamte Lifetime
https://download.opensuse.org/debug/update/leap/15.1/non-oss/x86_64/

Leap 15.2: Nur 1 Paket über die gesamte Lifetime
https://download.opensuse.org/debug/update/leap/15.2/non-oss/x86_64/

Leap 15.3: Nur 2 Pakete über die gesamte Lifetime
https://download.opensuse.org/debug/update/leap/15.3/non-oss/x86_64/

Leap 15.4: Kein Paket und damit kein repofile…

Deaktiviere einfach dieses Repo, da die Debug Quellen nahezu nie gebraucht werden. Und wer diese braucht, sollte die entsprechende Erfahrung mitbringen…