Plasma hangs after login on a fresh install


I installed openSUSE 11.4 today and I have a problem. After login, KDE Plasma hangs for about 30sec and I can’t do anything. The keyboard and the mouse are working, but if I click, I don’t get any response only after about 30sec.

This is a fresh install, 32bit, I’m using only the Oss, Non-Oss and update repositories and the system is up to date.

I have an nvidia 9500M GS graphics card, first I thought it is a driver bug, but I tried both the stable 260.19.44 and the latest 270.41.03 drivers, and was no difference.

I made an another user to try with a clean kde, but the same happened.

I have nothing in my Autostart directory, and I cleaned also the /etc/xdg/autostart dir, leaving there only the pulseaudio related files.

So I don’t know what causes the system to hang, can somebody help me to fix this?

Thank you!


Is the KWIN effect are activated ? If so, deactivate them and see if the symptoms are still there.

I heard there was a problem with the nvidia driver and the 32 bits openSUSE 11.4, but don’t know if it’s fixed. Someone knows?


I turned off the desktop effects. The only thing that changed was that after login, right click on the desktop brought up the menu, but still no response from the panel or run dialog for about 20 sec.


I have exactly the same behaviour, with the 64-Bit version.

Additionally, my desktop also hangs when I press the power-off button (which is configured to immediately shut down): The desktop hangs for about 30 seconds before shutdown is initiated.

I have an Intel graphics card, so this is most likely not an Nvidia driver issue.

Any ideas?

At least, I found a solution for the 1st part of the problem:
Apparently, the evil daemon that blocks the system after login is ‘KMixD’.

I deactivated it in
‘System Settings’ -> ‘Startup and Shutdown’ -> ‘Service Manager’ -> ‘KMixD Mixer Service’.

I have no idea what this guy is good for. Anyway, everything works fine for me without him. Especially, nothing blocks my desktop after login :slight_smile:

Nevertheless, my problem with Shutdown still remains…

Your problem with shutdown is cauzed by a bug in powerdevil, which is present all over the 4.6 series, on every distribution I tried. Powerdevil hang for about 30sec or more before any action, be it shutdown, be it only to show the shutdown dialog. It is a known problem, I saw many bugreports of it, let’s hove it will be fixed for 4.7 and backported to openSUSE.