[Plasma] Getting "(Application) is running in background" notification everytime I start a flatpak program

I’m not quite certain how to troubleshoot this, though every single time I start any program I’ve installed through flatpak (Librewolf, Quod Libet, etc) I get this notification. It wouldn’t be so much of a nuisance if it disappeared after some time, but I have to manually dismiss it every time I open my browser.

I’ve tried disabling the notifications for Flatpak programs separately from Zypper, though I can’t seem to find a way to do that.

If there’s something I’m missing, I’d appreciate any assistance. Thanks in advance.

Welcome to the forum!!

Hmmm. I run Flatpaks and have yet to see the notification.

Might try this - tap the “Find out more” button - there should be an option to allow the app to run in background.

I think there’s a system-wide solution, but not at my computer at the moment.

The only available options are “Allow” or “Force quit”. Allowing it and restarting seems to do nothing, as the notification just comes back upon launching it. I’m not certain why, but it seems some programs (Quod Libet, HandBrake) only do this on occasion, where are Librewolf (And base Firefox, it seems) does it every time. I’m not sure if it’s just an issue with it being a browser, though.

Well, I just installed LibreWolf as a Flatpak.

Ran it, navigated to website, changed some settings, then exited the app.

I did the above sequence about 10+ times. For me, I never saw a Notification.

Have you executed the app from a command line window? There might be some output that provides a clue.

Okay, no clue how, but it seems restarting my entire system after having explicitly allowed it background access fixed it. Appreciate the help mate.