Plasma error on update

I have just updated to LEAP 15.1 from 42.3 and upon booting it is saying plasma is unable to start as it could not correctly use OpenGL 2. Please check that your graphic drivers are set up correctly.

From what I remember I used the G04 Nvidia drivers on 42.3. Please can someone help in letting me know how to get around this :slight_smile: I can’t actually do anything at the moment. It is set to automatic log in (it’s a PC at home, not a laptop) so can’t even get to the log in screen.

Any help is greatly appreciated.

Forgot to add, once I close the windows I am left with a totally black screen with a very large cursor/arrow. Thanks.

I managed to get to a text log in, I used zypper to install the nvidia repo, uninstall then reinstall my drivers using the newer repo but still no luck. When I close the first window I am left with ksplashgml closed unexpectedly…


NVIDA driver may not update depending on the update method and NVIDIA repo availability.

Log into a terminal at boot as root and add the NVIDIA repo if needed and add the drivers then reboot.

Note also if this is a notebook then you would need to deal with Optimus hardware and use either suse-prime or bumblebee to deal with the hybrid graphics.

If you need more detail ask

hmmm should have worked. This is why I always do a fresh install and just keep my home. I keep two root partitions that I rotate for each new version I install that why I can drop back to the previous if the new version has problems.

Can you boot with nomodeset??


I had a look at the repos using zypper and found that opensuse 15.1 update was not enabled. I enabled it, refreshed the repos, then forced an update. It asked to update nvidia drivers which I’m now doing, let’s see what happens with another reboot…

AHA, I’m in!! Woo :slight_smile:

Thanks :smiley:

I have the same problem, but in a new installation of Leap 15.1. And I don’t know where to report.

Have same issue after recent update in Tumbleweed.

First off tell us the GPU hardware and if this is a notebook.

Can you boot with nomodeset?

At boot screen press e
Find line startin linux or linuxefi
go to the end of that line (note it wraps)
add a space and nomodeset
F10 to continue boot

this will load fall back drivers that shold work with any hardware but with reduced proformance. but it will allow you to install needed drivers

Thank you, I will try it, and report the result.

It’s a GeForce 8600GT (the driver is nvidia 340xx). And is not a notebook.

Did it work OK before you installed tainting drivers? All my PCIe GeForce and Quadro cards, including one GeForce 8600 GT, work fine in 15.1 (and TW) with the upstream default DDX, modesetting, by having neither NVidia drivers nor xf86-video-nouveau installed.

as in
written: 15.1 and drivers G03 from NVIDIA Repo (legacy-drivers) doesn’t seem to work due to missing dependencies ->kernel-source package should be installed but will not by default. this leads to errors in compiling the modules and to missing modules for nvidia(.ko). Unfortunatelly there is no warning when installing the packages. You end up, having blank screen or only a mouse-pointer and thats it.

I have problem on two pcs. Dolution is a bit rough - for me it worked:

  1. Install kernel-source
  2. i didn’t manage the build of nvidia-module with yast, no matter how many times i installed the nvidia-packages, so after install the drivers with yast i did:
    cd /usr/src/kernel-modules/nvidia-340…whateverversion-default
    → this builds the kernel-modules
    after that, modprobe nvidia should work. Restart an check if drivers/plasma works.

Btw: i had some error not getting nvidia-uvm working. Anybody got that running?
Regards, Daniel

Thank you! That solve my problem with the driver G03 too.