plasma-desktop crashing kde 4.2.70

KDE 4.2.70 (KDE 4.3 >= 20090415) “release 1.4”

anyone else getting crashing today from KDE4/Desktop/UNSTABLE?

i deleted all plasma-related rc (config) files in ~/.kde4/share/config but it still keeps crashing with this:

Object::connect: No such slot DefaultDesktop::configureRequested()
Object::connect: No such slot DefaultDesktop::configNeedsSaving()
QLayout: Attempting to add QLayout “” to QWidget “”, which already has a layout
plasma-desktop(716) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: “HAL-Power”
plasma-desktop(716) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: “NetworkManager 0.7”
plasma-desktop(716) NetworkManagerApplet::NetworkManagerApplet: 147
plasma-desktop(716) NetworkManagerApplet::NetworkManagerApplet: true “” “”
plasma-desktop(716) NetworkManagerSettings::NetworkManagerSettings: “org.freedesktop.NetworkManagerUserSettings” true
plasma-desktop(716) NetworkManagerSettings::NetworkManagerSettings: “org.freedesktop.NetworkManagerSystemSettings” false
QObject::connect: Cannot connect (null)::toolBoxToggled() to DesktopView::toolBoxOpened()
Invalid D-BUS interface name ‘org.kde.plasma-desktop.PlasmaApp’ found while parsing introspection
ERROR: syntax error
ERROR: syntax error
ERROR: syntax error
KCrash: Application ‘plasma-desktop’ crashing…

forgot to mention, i also tried removing ~/.kde4 but that didn’t make a difference either.
if that doesn’t work, something is seriously wrong.

and yes i know it is “unstable”.

I’m using release 1.7. No problems here. I use to have plasma crash when I tried to shutdown or restart. I’m not sure when it stopped doing that.


I am currently experiencing the same problem. Does anyone know if there is currently a fix for this.

It seemed to have appeared when QT updated from 4.5 to 4.5.1

I am on release 1.7 and after the upgarde to QT 4.5.1, plasma crashes during shutdown.

i have been using icewm as a stopgap measure. i am using Qt 4.5.1 also. maybe that does have something to do with it…

luckily, version 4.2.71 has fixed the issue, whatever it was.

dang! i spoke too soon. i customized my desktop from the default and now it crashes again. i removed all plasma config files but that didn’t fix the issue and now this is what i get with 4.2.71:
pastebin - collaborative debugging tool

Ok well it is working for me now. Hopefully it will stay that way.

you may not want to log out then. after logging in, i made my customizations and then logged out cuz of some updates and logged back in and boom! same problem as before.>:(


upon package inspection in yast (KDE4/UNSTABLE/DESKTOP repo) i noticed there were more than several packages still stuck at 4.2.70. it was cuz of repo preference. so i simply told yast to install the 4.2.71 versions of those pacakages and voila! solved.

hope this helps some one.

I tried, but the repo has no 71 version of KDE4-filesystem and python-KDE4. They are both at 70. I updated what I had, but then get an lnusertemp error. Guess I’ll wait in hopes that the updated versions show up soon.

i don’t think kde4-filesystem is part of the problem. i still have version 4.2.70.x installed and all is working fine. and as for python-kde4, i don’t even have it installed.

Thanks Echoes. I downgraded to 4.2.2, then upgraded back to 4.2.71 and it worked. Not sure why. Maybe I borked something when I manually forced the .70 to .71.

They will be bumped to 71 with next rebuild.