Plasma And System Language Change

Selected Italian formats and system turned to Italian, but it’s still set to American English, what don’t I understand please?
Thank you.

You do not tell what the firtst two picture are from. I do not recognize them as being a sytem management tool. Are they from a desktop configuration tool? In that case, they do not set the system language, but the desktop language for that desktop for that user.

The last is from YaST and that will set the system language.

First images from System Settings -> Regional Settings, last one as you said from YaST, it’s not working: system language is still Italian and I don’t have any secondary languages installed, tried removing and re-adding English (US) but it done’s work.

I now assume those first two are from KDE (you never told you are using KDE!!!) System Settings. Despite the name “Sytsem” Settings most of what you find there are Desktop Settings. They are for the user (and NOT for the system).

YaST is for the system settings. Thus, when you want to set your system language, you go there. It has nothing to do with the settings from KDE (for the user).

When I go there and open the Primary Language menu, there is a list to choose from and Italian is one of them. It that not so in your case?

Please check the last two screenshots I’ve posted: I did set American English in YaST and the system is still in Italian, even after reboot or removing/r-adding, it’s driving me mad.

Maybe you are hit by this:

Thank you, posted in that thread as the workaround suggested didn’t do the trick for me.